ARC - Swedish ISPs does not provide static public IPs that are not CG NAT

Hi all, just want to inform that 99% of the Swedish ISPs does not provide static public IPs that are not CG NAT. This means port forwarding is not possible. Thus, the ROON ARC will only be possible to use with a separate VPN solution or when connected locally (where Roon remote work).

1 Like

5 posts were split to a new topic: ARC - Polish ISPs and IPv6/Carrier-Grade NAT

Thanks for the info Carl-Johan.
So I guess there is no Roon for me:(
I’ll think I’ll stop recommeding Roon to my Swedish friends from now on. to bad.

1 Like

Please let them check if they can get a public IP from their ISP, most ISPs offer this without a cost but it is not 100% available. Wait for IPv6 to be deployed.

1 Like

Static IP is not a common thing in Austria too - is this really necessary to use ARC? Info please if anybody understood it… :smiley:

2 Likes

Hi everyone,

The team is aware that many Swedish service providers have implemented IPv6 at the residential level (with DS-Lite IPv4 tunneling sometimes available, but implemented in such a way that it doesn’t allow for port forwarding). Bollnas, Gavelent, Soderhamm Nara, Sandnet, Ljusnet, Bredband2, Bredbandsbolaget have all rolled out some form of carrier-grade NAT since 2014, to give examples that I can think of so far.

Telia, Telia Öppen Fiber, and certain Splitvision plans do not appear to have universally implemented carrier-grade NAT that interferes with port forwarding.

The implementation of IPv6 and whether a static IPv4 address might be available will vary widely by service provider, depending on your locality.

I strongly suggest if you’re encountering a 502 error in your port forwarding diagnostics, you still post here or in a dedicated topic thread, and the tech support team will have a look at your network and connectivity situation. There may still be a double NAT layer at the local network level responsible, and port forwarding may still be possible.

Until then, please recognize that we understand your frustration, and we’re investigating solutions to IPv6 implementation that will open up ARC to as many Roon users as possible.

1 Like

I have now requested a public IP (no CG NAT) from Bredband2 and will let you know how it goes. Or, if they can give me a IPv6 address (need to upgrade the Fortigate as it is IPv4 only) that would do as well. From my knowledge it is not that common that ISPs in Sweden do approve this kind of request, but i urge everyone to try. And be sure you ask for “Public, no CG NAT, static IP address”, if it is static or dynamic is a secondary question. My CG NAT address today is told to be static, but it is not, but usually i do get the same IP anyway, which might be due to the CG NAT ■■■■■ i do not know. Long lease time!

Now, in a couple of hours from the request, i have received a public IP instead of a CG NAT from Bredband2. Excellent work Bredband2 and the best thing is my port forwarding in the Fortigate worked instantly. Roon ARC working excellent. Thank you.

4 Likes

This is great news! I am hoping that others in your area will have the same experience in dealing with Bredband. I appreciate you returning to let us know.

Wes

In Denmark you have to pay to have a static IP, 6 usd/month, if ARC support CarPlay I will consider it…

I don’t understand how I can acces my 10years synology NAS for outside without any problems, and this doesn’t work?

Probably because you are using Synology’s cloud based method for keeping the connection alive? The way Roon chose to handle this (no cloud, just port forwarding) is the proper way in my opinion. Cloud based solutions (especially IoT/smart home ones) are great until the provider has issues or a security breach.

3 Likes

I have the same problem and also ordered and received a static public IP (Bahnhof) - BUT I can’t get it to work - is it possible to get some advice on how you solved it?

Same problem here. I also hav a static public IP with Bahnhof as of this morning, and I have tried Port Forwarding, but to no avail. I have a Zyxel ex3301-TO from Bahnhof. If someone get this router to work, let me know.

Check that you are 100% sure you have a NO CG NAT address. Try to make a port scan from an external site (available online) after you’ve configured the port forwarding. What router are you using?

Ok, about the address: I just ordered (and have to pay 50 SEK a month for it) but if I now have the right kind of address I cannot say (they just said “static public”). I have a TP link Deco X90. It is a lot of settings (and more) I don’t really understand (maybe I made some misstakes). Thanks for the advice. I will call Bahnhof tomorrow and check. Then try to make a scan if necessary.

Hi Richard,

If you now have a static public IP you should be good with forwarding. Please take a look at this guide I found. It looks like it might be the right one for you.

Wes

Not a static IP but a public IP v4 address that is eligible for port forwarding. Some ISPs might provide only both in a package (and maybe only for business accounts), but static is most likely more expensive and you only need the “public, for port forwarding” part.

1 Like

Thank you Wes. I will try again and also read the guide (and yes I have got a public static address and not the CGNAT-version). It sounds hopeful that it should work with a static - public address. Thanks!

2 Likes

I am in Denmark also at two locations. With Stofa on Fyn in a private villa I have got ARC working without any config on the ISP router. I did have to port forward on my internal router (google nest) and also McAfee firewall.

We are back in Copenhagen in a few days where we are part of an apartment scheme with Fibia. So I don’t know yet if that will work without a static IP.

1 Like

Ipv4 is dead. Not enough addresses available, that’s why all isps changed to ipv6.

Is it still a feature if maybe 10 % of users can access it? And honestly, who of those does not have a tidal account anyway?

It seems Roon becomes an old men software, holding tightly to those files one accumulated over his life… :stuck_out_tongue_winking_eye: