ARC: Unexpected Playback Error, Seemingly Random Conditions [Ticket In]


I have generally had really good results with Roon ARC and have not experienced any connectivity issues. I have been driving around for the last couple of days and have no streaming issues when in my car and the experience has been good.

One issue though, is that occasionally a track will stop at any point when playing and there is an error message in the ARC app ‘Unexpected playback error’

I do not think this is related to any bandwidth or streaming issue as the song will stop at the exact same spot if I try and start it again. My only way to deal with this is to go to the next track in the playlist. The same song plays just fine when using Roon 2.0 remote when at home.

This seems random in terms of which song this happens on, but once it does, all I can do is go to the next song.

This already be a known issue thought I would ask here.

Generally speaking my files at home are FLAC. In ARC I have the app automatically pick best quality. As I say, don’t think this is a drop out due to streaming of network.

Any ideas?



Just some additional data points here.

This is the error I see. If I skip back to the previous track then skip to next to restart the David Gilmour track it will stop at exact same point with the same error message.

The screen shot of the Camel track I looked at the audio chain and note the song was downloaded so I don’t think network or streaming related.

Both these songs play fine at home from my Nucleus and remote 2.0

thanks in advance


Just wanted to add that I have this issue once in a while too, and persistently just on random individual files.

2 posts were merged into an existing topic: Dropouts and skipped tracks

For my home internet, I have an average upload speed of 20 mbps. Typically no one else is extensively using the internet at home during the day. On ROON ARC, I can play anything from 16/44.1 to 24/192 to DSD 64 currently when I’m at work on the Wi-Fi. That includes the local files not downloaded and Qobuz. As for Tidal mostly MQA tracks, it doesn’t seem to want to play those but sometimes it struggles with the cd quality tracks with no MQA. I just get unexpected error. Wondering if that’s maybe a bug. Once I switch to using my data, I can play those MQA tracks just fine. So I’m not sure what’s going on or if maybe it’s just a weird issue with the Wi-Fi at work. I also have no trouble playing MQA tracks from Tidal through ROON ARC when connected to my home Wi-Fi.

Hi @Allan_Rentcome,

Thank you for your report, and please accept my sincere apologies that it’s taken us this long to reach you in the queue.

We resolved several issues with transcoding with the release of the second build of ARC, 2.0.1, last week. Have you experienced any of these playback errors since updating? Here are the release notes: Roon 2.0.1 and ARC 1.0.2 are live!

We’re also tracking a few edge cases in which upsampling significantly will fail on Android devices. Your screenshot appears to be an iPhone, and signal path shows no upsampling, so I’m assuming these issues aren’t affecting you. However, out of curiosity, what endpoint are you using? Do you experience playback issues without Bluetooth, using only the phone’s system output?

We’ll be watching for your response and thank you again for your diligent report and patience.

I’ve been seeing this same issue on my iPhone as well. So far, it’s only happened for tracks which have been downloaded to the phone. The track stops at the exact same place every time that I play it and won’t let me go any further unless I skip to the next track. My guess would be that the file has been corrupted during the transfer to the phone. I’ve solved this for some files by deleting them from the phone and downloading them again.

Hi @Dan_Boulet,

Thank you for the report. We’ve had a look through diagnostics - the issue you’re reporting, while separate from the transcoding failures described by other users in this thread, is a known bug for which we have a fix in QA. We anticipate we’ll have this locked down in an upcoming release; I’ll notify you here once that’s the case since I don’t have a precise timeline at this time.

I’m also seeing potential evidence of filtering in your downstream connection, and unexplained lagging in your upstream connection. Do you have a VPN, enterprise-grade security, proxy server setup, or any other network software in play here, by chance? It doesn’t appear to be causing any issues with ARC, but it may affect performance eventually if you have poor cellular service at some point.

I have the same problem. I have checked that the same track can be played on Roon local.

Thanks, Connor. I’ll keep an eye out for a future release which fixes this issue.

To answer your question: no, I don’t use any out-of-the-ordinary network software, so I don’t think that could be causing any of my issues.

This also happens to me with (some) files downloaded to my iPhone, whether in on or offline mode. Some tracks stubbornly stop at a given point and I get the error message. Happens only with downloaded files: streaming works perfectly when online

On tops, downloading is a terrible experience: crashes, freezes, etc. But that’s another thread…

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.