ARC was automatically configured and reported as working but didn't work outside of my network

Roon Core Machine

Intel ROCK as recommended and specified by Roon

Networking Gear & Setup Details

generic Linksys home wifi/ethernet router

Connected Audio Devices

Sonus, Bluesound, RaspberryPii all cat 5 connected

Number of Tracks in Library


Description of Issue

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
My router has Upnp and NAT enabled ROCK has a static ip address. When I first installed 2.0 and ARC it worked but only via my wifi anywhere else it would crash or say “poor connection” When I reset the ARC connection it fails to make a connection and gives the above error message.

Ok, so I installed ARC on my wife’s iphone and it works outside of our Wi-Fi. This was after I did a manual configuration of a port for ARC on the router. So it appears to be a problem with my android. I have previously sent the error log that my phone generates although it might not jive with my account as my phone has a different gmail account than my Roon account. I will try uninstalling it and reinstalling it on my phone and see what happens.

ok uninstalling the arc app and reinstalling seems to work. It connects on the wifi network and also through verizon. Hope this is the cure and also hope this might help others.

Mark, we’ll mark it as solved. Please update if you have issues going forward and enjoy ARC.

Ok so I went out away from home driving in areas that I have had no trouble streaming Tidal and Pandora and it would not work at all. “Poor connection” notices and a couple of crashes. While driving I can access my library and browse it (I assume my phone is not storing this data base?) But it will not play anything. I used to have a WD app that allowed me to access my NAS and play music and videos from anywhere I had cell service but it was not supported anymore. I am throwing in the towel and will revisit in the future. Needs some bugs worked out it seems.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.