Archive Corrupted Error in Etcher

When attempting to flash both the .bin and the .xz compressed image of Ropieee 373, I’m getting a corrupted image error in Etcher. Any thoughts on a work around:

Delete the image and download again.

Thanks Martin. I’ve tried that three times already. I just tried a DietPi image as well and got the same error. It might be an etcher issue.

Are you saving locally? I have had issues in the past with using network shares.

Yeah, I’m saving locally. I’m wondering if it might be a Mac Catalina issue. Just spinning up Parallels to try it in Windows instead.

It’s another Catalina permissions issue. You can either run etcher as root (not recommended), or wait for an update. To run as root, open the terminal and enter the following:

sudo /Applications/balenaEtcher.app/Contents/MacOS/balenaEtcher

Further details: https://github.com/balena-io/etcher/issues/2843

4 Likes

Have a go with ApplePi-Baker v2 which has instructions on granting Catalina Full Disk Access
balenaEtcher is 226.4MB, ApplePiBaker is 8.4MB. I really wonder what those extra 218MB are up to?

2 Likes

Just to loop back here, Windows did solve the issue. Thanks for the PiBaker suggestion though. Parallels is a pig on my older MacBook.

1 Like

You’ve earned the MVP badge for this thread @MJB, thanks for your insight. Was able to quickly run Etcher as root and get my image on the card. Will also download ApplePiBaker for the inevitable next time I need to flash a card :slight_smile: Thanks.

Quick Edit: get rid of the ` when you run the terminal command.

1 Like

I had this problem today and solved it by removing Etcher (drag app to trash) and re-installing it fresh. No more error message.