Are you online Please check your internet connection

Thank you @Jim_F ,

I have tried several times,but it’s like a loop.When I switch to PC,I am prompted to unauthorize rock,click and no response.Then I switch to Rock and prompted to unauthorized PC.I even don’t know how I jump out this loop at last.

It really sounds to me that you have something blocking traffic between your local network and Roon’s servers. Have you got a firewall or parental controls enabled on your router?

Hi @Robem ,

I agree with your opinion.

The router has a basic firewall setting,No parental controls or specific URL filter.I never change the setting and have used roon for 4 years.

So I need support team to check the log files and server.I called my ISP and they can do nothing.

I hate to be the bearer of bad news but the chances of getting a timely response are very small. If it were me I would be trying to diagnose the issue myself using some tools like ping, nslookup and traceroute. Depending on the outcome of the testing, I’d also be preparing for the possibility of resetting the Linksys router back to factory defaults. You might find some clues to the root cause in the log files yourself, I have scoured them myself before looking for errors and using searches to point me in the right direction. I wish you the best of luck.

Signed a jaded realist.

I do some diagnosis and guess that the root cause is the core can’t connect to * unfortunately I myself and my ISP can do nothing now,so I need support guys to confirm and tell me the server and my account status is OK.

Are you able to identify where the packets are dropping? You can test for that using a traceroute or tracert command depending on your operating system.

I just noticed that you specifically said Linksys routers (in plural). Is that true or a typo?

It’s a typo.Actually I use the linksys router as AP you can ignore.The rock is connected to the main router directly.I use tracert and get no response at early node,but it’s similar to tracing some reachable URL such as I think this is for reference only,and I’m not very sure the reachability to is the root cause.All things happned after I upgraded roon and logged out.

2 posts were split to a new topic: After Update, Network Error: Please Check Your Internet Connection

What is the main router? That’ll be an important detail that might help support if they read this.

Remember, using tracert is tracing the route from your Windows box to the target, it is not tracing from your Roon server to the target. It’s still a valid test because it is testing routing through your router. What are the results of a tracert to

The main router is a ubnt edgerouter.This little box has worked very well for 7 years,along with rock for 4 years.Tracert to or is successful,while etc. is fail.

And where does the tracert stop when targeting ? Does it stop at the EdgeRouter or does it pass through and fail somewhere else on the route? How many hops does the trace make before failing?

Pass through the router. But only 3 hops including the router.I tried again, the result is Pass as expected.But I don’t know what they were when I could use roon some days ago.

Hi @Q_XY ,

Apologies for the slow response here. I looked over your logs and I noticed that it appears that multiple Roon services are failing - metadata queries, login, general authentication, and music analysis.

I noticed that you are located in China, so it is possible that the national firewall is blocking Roon services.

You account status looks good from my end, it just looks like a failure to communicate with our servers.

Do you have backups of your Roon database? The nuclear option would be to try to wipe the ROCK database / PC database, reinstall Roon fresh and restore from a backup. You can do this with the below instructions:

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your ROCK’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

If the remote still does not connect, you can wipe the Roon app on it as well:

  • Exit out of Roon
  • Navigate to your Roon Database Location (for the Windows remote, under %localappdata%)
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Connect to ROCK server
  • Verify if the issue persists on fresh database (without restoring first)
  • Restore database

Thank you @noris

I am confused by two questions:

  1. As far as I know,very few people face this problem,It’s strange.
  2. Is it because I never log out that I can use roon in the past four years?

And will the rebuilding be useful since the FW is always there?

That’s quite the detail that you left out there, you could have saved us all some time. is hosted on Google Cloud infrastructure whereas is not. It is no surprise that China would be blocking traffic to Google IP address ranges.

I have to wonder, what are Roon distributors that are located in China advising their customers is the best approach? It might be worth a chat with one of them?

@Robem Your suggestion is reasonable.But it’s strange that in local forum few people declare they have this trouble.

@noris Hope roon provide a solution.


I have seen more and more chinese users face the problem that they cannot connect to roon servers because of firewall.So is there any possibility that roon deploy their services on other cloud servers than Google?


Hi @Q_XY ,

Have you confirmed with others in your area if this issue affects others? I spoke to the team regarding this, and they have mentioned that this issue is most likely due to your ISP or the national firewall blocking this. To try to narrow it down you can try the following:

  1. Bring your Roon Core to a friend or family’s house and see if you are able to log in there
  2. Try to switch to another Roon Core (PC) and see if you are able to log in with that Core
  3. Try a VPN on your router

Hi @noris

I can confirm that it’s due to the firewall of my ISP(China Telecom).But in other provinces the blocking stratege may be different.This can be deduced easily by the result of ping ***
.In my province the result is Fail while in some other provinces the result is Pass.

In general I have seen more and more people facing this problem.

So I wonder if you could add some cloud service vendor other than google.