Artist image will not load [Ticket Open]

I have been trying to get an image for each artist in my collection. Using edit and add image generally works fine.
Occasionally though some images will not load with the failed to load image from clipboard message. Through experience I have learned that anything derived from a youtube site, e.g.
will never load.
Annoying, as these are common, but I know now not to try.

However what is wrong with…
This also fails.

I’m running linux based roon server on a separate laptop, and a remote on my samsung tab s2 tablet. I don’t think image size is an issue, I’ve had bigger load ok.

I’ve looked through the knowledge base and forum threads, but can’t find what I’m doing wrong.


Hello Brian

I don’t suppose it helps, but I downloaded the image from your first link, and assigned it to an arbitrary artist for whom Roon did not have an image.
Works fine for me. (Roon Core on Win10/NUC, edited via Roon Remote on OSX.)

I am curious to know the outcome here!

1 Like

That’s funny. I had assumed the problem universal. Evidently not…

So, I loaded Roon onto my PC, and tried there (as a remote). It worked.

What’s different about Android? Or is it Samsung. Can any nice fellow forum reader try a different android tablet please?


Hi @BrianW ----- Thank you for the report and sharing your observations with us. Both are appreciated!

We are going to look into this behavior and see what we can come up with on our end. Once I have some feedback I will be sure to updated this thread accordingly. Your patience is appreciated!


Hello Eric, sorry for the late response, I’ve been away.

I’m not clear what sending a tarball will achieve. The url is all you need. I simply copy and paste the url into the ‘add image’ part of the edit and get the failure message. I guess that as you can’t reproduce it with your androids, the problem must lie in my Samsung tablet. My wife’s samsung (same model) shows the same error (I emailed the url to her and she copied that - no tarball). I don’t have any different android devices to try ( I did try my android sony phone, but it seems you can’t edit with those).

The tablet is a Samsung tab s2 sm-t810 9.7inch 3GB ram, android 7.0, running roon 1.3, build 233 32 bit. The core is build 234 64bit.

Do you have this model?


Hi @BrianW ---- No worries at all and I must apologies as there was an internal miscommunication on the next steps here. Our tech team has what they need, so the tar ball is indeed, not needed.

I appreciate you understanding and once my report has been updated I will be sure to reach out in a timely matter to offer some additional feedback! Thank you for your continued patience!


Just for info, I tried again with the new build of Roon; unfortunately the images still fail to load.


Hi @BrianW ----- Thank you for the update after testing with the new Roon build!

I wanted to touch base because our QA team was able to reproduce this issue and in light of this a ticket has been opened with our developers who are currently investigating. Once I have some more feedback from my team/devs, I will be sure to update this thread accordingly.

Your feedback and more importantly, continued patience are very appreciated.


No problem Eric, I knew you’d get there in the end.

@Eric, this ticket can be closed. Somewhere along the way the problem was fixed. I don’t know when the developers did it but thank you.