Artists, albums, tracks with diacritic marks don’t load

Core Machine (Operating system/System info/Roon build number)

Nuc10i5 rock version 1.7 build 610 (all installed yesterday)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired Ethernet, router - switch (Cisco 2960) with NAS (Synology) - switch (English electric 8) with nuc and streamer

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Naim streamer (Roon ready)

Description Of Issue

Have been running run core on Mac Bock Pro Since June, yesterday I installed a NUC10i5 and rock to replace the Mac as core. I got it going after a lot of searching (the installation guide really need an update, legacy mode etc). I restored my library from a backup and all looks good until I try to play tunes from my library on the NAS, and specifically tracks with diacritic marks in the artist, album or song title. Very common in Swedish names and words in general using å, ä, ö etc. I get “playback was interrupted because a trac failed to load”. I have tried to restart the nuc, the iPad app and also tried Roon from my Mac, no change!

This didn’t happen with the Mac as core, also the Tidal versions play just fine!

Is there a fix for this problem, or have I wasted my money on the nuc?

That Cisco is a managed switch see if the following helps. From the Roon Networking FAQ:

Managed Switches

Managed switches can be very robust, but they are often designed for professional installation, so in many cases the out-of-box configuration is not right. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. If in doubt about any of this, try temporarily replacing your managed switch with a “dumb” switch to see if things improve.

Thanks, but this seems not to be the problem. I changed to a Netgear gs105 no difference, also swapped in an Asus switch instead of the English Electric also no change.

To make it 100% clear, files not including these marks play fine.

All worked with identical setup using a core as server on my Mac, problem occurred with NUC10i5 and ROCK.

Any further suggestions?

Hello @Jakob_Westrom, and welcome to the community! I’d like to get a copy of the files with these characters over to our team. Could you please upload a few of them here? Thanks! Let me know when you’ve had a chance to upload the files.

Hi I uploaded three songs two of them contain these diacritic marks, the third (01 Tide Of Trepidation.aiff) the artist is Esbjörns Svensons Trio that failed to load. If I change the Artist tag to E.S.T. using iTunes which also change the path name the album plays.

music/iTunes Media/Music/Esbjörn Svensson Trio/Viaticum/…
music/iTunes Media/Music/E.S.T_/Viaticum/01 Tide Of Trepidation.aiff

Paths for the other two:
music/iTunes Media/Music/Crosby, Stills, Nash & Young/Déjà Vu Live/
music/iTunes Media/Music/Anders F Rönnblom/Ramlösa Kvarn/

Thanks for the files @Jakob_Westrom. I’ve sent them to our team for further analysis. I tried them on my DAC and was able to play without issue, but our team will want to test on a range of equipment.

Hi, I have solved and believe I have identified the problem. I believe the backup restore somehow corrupted the paths including diacritic marks (artist/album/track) when using the backup from my MBP-Roon Core when restored on my new NUC/ROCK. The clue was changing the artist from Esbjörn Svensson Trio On one album, first to E.S.T and that worked and finally changing it back again and that worked as well!
So after temporary changing the path Of my music folder on the NAS to another folder and back (and Roon re importing the library) all seems fine🙂

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hello @Jakob_Westrom, that’s awesome news! Please let us know if you have any further issues.