Artwork disappeared from all devices

Roon Core Machine

Core SW : RoonOnNAS V 20211105 by Christopher Rieke
Core machine : Synology DS720+ with 10GB RAM, 2x 4TB WD HDD and 2TB SSSD cache
Core machineOS : DSM 7.0.1-42218
Roon build : 1.8 (build 884)

Networking Gear & Setup Details

600MB cable internet connection, Linksys Velop mesh WiFi, Core machine connected with network cable to Netgear GS728TP Switch, Roon clients on MacBook,iPad and iPhone

Connected Audio Devices

2x Sonos Play:5, 1x Sonos Play:3, 2x Sonos One, 1x Sonos Move, 1x Sonos Playbar, 1x Sonos Connect. All running on S1. And one AppleTV4

Number of Tracks in Library

I don’t use a local library, I just use a Tidal subscription

Description of Issue

Hello, I’ve been using the above setup without any problems for almost a year. It’s been flawless so far. However some time ago when I updated to another build, all artwork started to disappear. I have not been able to solve the problem. This is what I’ve done so far:

Installed new core software on the Synology
Restarted the Synology a few times
Restarted Roon on all clients
Cleared the image cache a few times

Sometimes after clearing the image cache, a few album artworks show up, but for just a few minutes and then still everything stays empty. See attached screenshot.

I realise that the core SW by Christopher Rieke I use is not official Roon software, but I really have no other solution to build a core on mother machine. I hope someone can point me in the right direction to solve this. Many thanks!

It might be you are having network issues connecting to Roons servers. The first thing I would suggest is to set your DNS to or

Hi, thanks for the suggestion. I also did a factory reset on my Linksys network. So, I reset it to factory settings and added and to the DNS settings in my Linksys. After that I cleared the cache in Roon. Unfortunately it had no result :frowning:

If you run a firewall on your Synology NAS, disable it as a test.

Yes, firewall is on. But it was also on when Roon worked fine. But, of course I tested your suggestion. Disabled it, cleared the Roon image cache, but unfortunately it didn’t help.

Did you also restart the Roon Server process on the NAS after disabling the firewall as a test?

Your issue sounds strange to me. If Roon Server can reach the Roon cloud and no firewall is blocking communication with Remotes and Endpoints, what else is left? Do you use a VPN or IPv6?

I guess It’s similar to a metadata issue I have had for some time, where metadata are intermittently (but not always) missing from the now playing page using Roon Radio.

My Roon server can reach the Roon cloud and no firewall is blocking communication with remotes and endpoints. I too was advised to change DNS servers, but this is not something allowed by my ISP.

BlackJack, thanks for your help. I have tried to do it again. I disabled the firewall, cleared the image cache and I stopped and restarted the Roon process on the Synology. Still no album art. It does play music fine, but the album art isn’t showing up.

This is affecting me for just s few albums, its definitely a bug and not a network issue as it only came along with 880/882 several others have same issue. I don’t use a NAS and use ROCK.

Same problem here - using ROCK. Some artwork missing on some devices, but not all. Clearing the cache doesn’t really help, as different artwork goes missing after doing so. The issue started with the 880 update.

All, I have no idea how, but the problem solved itself. I have all album art back in Roon with Tidal. The only thing that changed last weekend is that I installed a new modem which was provided by my ISP. Not for this problem, but for higher speeds. But, I always have my modems set to bridge mode and don’t use the router options of the ISP modem since I use my own Linksys mesh system. So, not sure if the modem solved it. Wondering if @AudioDreamer his issues have solved suddenly as well.

I reinstalled the control app on my ios devices awhile back, which resolved the issue for me

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.