Artwork Disappeared In PC/Desktop Remote (after 1.8 update)

Roon Core Machine

Hello -
I have a Core running on a NAS with souped up RAM and the databse running on a separate ssd drive. No real issues to report for the last few months. ha smore or less worked perfectly.

However after today’s update to 1.8 - Many / most of my artwork files are missing on my desktop / pc player (running on a different machine than the Core). Oddly if I click the album, the artwork will appear
as normal.

My mobile and tablet devices do NOT have this issue and show the artwork as normal

I have attached what the current desktop / pc view to give an idea.

Any theories on what is happening? Appreciate any help or insight!

Hey @Sean_Agnew

Thank you for reaching out to us with your question. We’re sorry to hear that your album art isn’t appearing as expected. We’d be happy to help with this.

Let’s start by ensuring that the PC as well as your other Roon Remotes are also running the most recent update.

If updating all your devices doesn’t help please navigate to Settings>Settings>Clear Image cache>Clear Cache

If this doesn’t restore your album artwork then please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

We’ll be watching for your update Sean and get back to you as soon as we can.

Are these Qobuz albums or local files?

Do the Core and the desktop PC already have the same current version?

All devices must always be brought up to date.

I have observed that before synchronisation with the services, some images are still missing at first. Sometimes this also fails or takes longer.


The rebuilding of the database could also be accompanied by an improvement of the images, before better things come, old things have to go. Hence the tip to delete the cache.

More ideas:

Log out of Qobuz briefly and then log in again, possibly with a complete restart of the Core.

Hi Jamie!

  • Can confirm Desktop/PC and Tablet and Phone are running latest version of roon software

  • Clear cache does NOT solve the grey box / image file for PC.

  • Core is running on Roon 1.8 (build 831) on a Synlology 920+ (DSM 6.2.4-25556 Update 2). 14TB of spinning storage. 1TB for the SSD Cache. 12GB of RAM. Roon database running on an separate SSD via the USB port. Ethernet direct to an Orbi router. Speed test shows 900mb up and down.

  • PC / Desktop remote running Roon 1.8 build 1.8 (buils 831). Windows 10 home. Ryzen 7 3700. 32GB of ram. Loads of disk space. Also direct ethernet to the Orbi router.

Other things worth noting :

  • My library is 99% local files (vs streaming services etc). 1.27TB - 53,000 files.

  • Album cover appears fine / perfect when the album is selected and the tracklist is visible. When a click back to goto the library, cover appears Grey again

  • I have discovered that Settings > General > Allow For More Covers and Photos solves MOST of the artwork display problems, only giving grey squares when the album cover is not a perfect square BUT it displays many more albums on a row, I would prefer the older, less albums in a row look but if this is the only way, I’ll take it!

  • I would guess / bet most of my album covers are stored locally with the music files or copies URL image links via Discogs. Could it be a discogs issue?

  • PC/Desktop remote software crashes if I scroll too quickly (however can scroll much faster on phone and tablet. This was NOT a problem until the update.

  • I have restarted the Roon server on the core. That did not fix anything.

Hope these answers help !

Hi Uwe ! Thanks for taking the time to help …

  • All devices (PC, phone and tablet) brought up to update
  • Almost my entire library / the grey album boxes are LOCAL files. grey images are occurring
  • I just tried logging in and out of Qobuz and tried giving that a shot (no luck)
  • Restarted the Roon package on the NAS/Core and fully restarted the NAS

I am starting to think that there may be an issue with some of the artwork files which may (at least at one time) point to artwork files from Discogs. Does Roon have a max pixel size?

I don’t know any size limits, but I’m sure I’ve had problems in the past just because the extension *.jpg appeared instead of *.jpeg.

Actually folder.jpeg cover.jpeg or folder.png cover.png should not cause any problems. With some *.ogg files I had to put the embedded pictures first with MP3tag into the folder, so that it worked.

For me 1920 x 1080 is enough for artists and even 640 x 640 for albums but I also use more than double without problems so far. Discogs don’t make problems.

Had some hope w/ that .jpeg file change but that didn’t work.

I am way confused why the artwork displays with the “allow for more covers and photos” option selected …


maybe the own ones are only taken if more than the Roon covers are allowed :wink:

But this meaning only occurs to me now.

Solved my own issue. I tried deleting the 32 bit PC/desktop remote software, and installed the 64 bit version. That did the trick!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.