Artwork does not update

Hi @spockfish I am continuing to get slow or missing artwork lon my Ropieee that I use purely as a display and remote. It’s a pi3 connected via lan. I have raised this before and you mentioned this was down to the core being slow to update. Now I am not certain this is the case as my phone remote updates fine and changed at song changes in Ropieee If I click on where the image should be which switches the look of the Ropieee skin the artwork is there instantly. Is there nothing that can be done here?

Can you send feedback?



@spockfish Harry Me too…just looked up now and saw a dark album space not showing the album art that was previously playing and before my eyes it filled with the album image (track was about 60% completed playing. Only reason I caught it was I wondered what the track was.

Connected via Lan cable and display not being used for this zone, just display only

Feedback db2d4e1b57dd274f this was playing at the time I saw the image pop up

Another example pictures taken seconds apart and at around 50% track played

1 Like

It not just me then, that’s a relief it’s not my system. Been doing this since I set it up in Summer. Looks like you have the same case as me too.

These logs show something different then last time. Last time it was related to timeouts on the Roon server. This time it shows errors failing to download the proper artwork, but this time I think it’s on our side. For some reason it misses the link.

Weird thing: it does not happen all the time (at least from the logs). And the other weird thing about it is that I use basically the same setup without any issues.

I will built in some more logging to be able to figure out what’s going on.

I’ll keep you posted.


1 Like

Not a biggie…mine are all on the beta channel, not sure if that is different. Maybe all 3 units I have do it but this one I sit in front of more than the others.

Hi @CrystalGipsy,

I’ve pushed an update (to the beta channel) that improves the logging data, but I’ve also found a use case where there might be an issue with fetching the artwork.

Would be great if you can test this and see if it makes any difference.


Will do, likely not be using it until tomorrow though.

This update has borked Ropieee @spockfish took an age to install and after updating its taken nearly 10 mins to startup and it’s still starting up.

Says its up and running but no now playing, no extension running in Roon, no web interface. Restarted and it’s the same. Its just not starting up looks like a reflash will be needed.

This is a rather big update, so yes it will take time.
During this process the unit will restart at least twice. The web page is leading, so make sure it’s completely finished.

Sorry Harry it’s bust . It updated as I said it just wont start properly. Booting up is Super slow nearly 10 mins on each section eventually , says Ropieee is ready yet as I said no display, no running extension no network access at all.

I’ll had to reflash. It was updating for well over half an hour surely that’s enough time?

After the download step (which could take considerable time depending on your internet connection), de update step itself should take a maximum of 10 minutes or so.

It was left longer than that and I have a very fast 350mb/s connection. It’s moot now anyway as it needs a reflaah regardless. Just worried it will do it again.

Well, I’ve updated numerous times from stable to beta (testing this coming release), and so far all my attemps where succesful.

Its worked for me before to, just not this time.

Broken again Harry. It update to beta channel ok, but then updating to latest version it’s bust. It took a while to restart again, now have Ropieee screen up but its not getting any ip address in the UI. My router is assigning it one and I still get no webui.

So what does it end with? With the screen (web interface) saying it’s busy updating?

Can you send me feedback after you’ve switched to the beta channel?

No it gets this after about 15 mins of boot sequence. As you see it has no ip. My router has assigned it an ip but it’s not using it at all, no web interface assessible so cant send feedback from this install.

I reflashed, then switched to beta channel, it switched over perfectly fine. It offered an update so I downloaded it. Then followed install , went through the process , only reboot once then it gets to this stage and gets stuck.

Here it is in my router.

Clocks working though.