Artwork not displaying

Core Machine (Operating system/System info/Roon build number)

QNAP TS251 running QTS and Roon 1.7 (Build 521)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Hard wired through Netgear Prosafe 5 port unmanaged switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Meridian 218 on Ethernet

Description Of Issue

Some of my artwork is not displaying, as displayed below:

I have restarted the Roon Server application and also the QNAP server it sits on, and although it sometimes replaces the affected albums, others can be found to have vanished in the process. The artwork exists in the music folders and there is nothing I can find that would cause this to happen. It is something that only seems to have started to happen since the 1.7 update.
The music of the affected albums plays normally despite this issue.

Hi @Alan_McMillan,

Is this happening on all remote devices?

Hi @dylan

Yes it is.

A post was split to a new topic: Missing artwork and slow performance

Hi @Alan_McMillan,

Is this only for local files or also for TIDAL/Qobuz? I see in your example the album is identified — Do you have Roon set to use local artwork or is it using our artwork?

Hi @dylan
I don’t have either Tidal or Qobuz so this is purely a local files issue. Every album folder I have has its own artwork file and Roon uses that in all cases.

Thanks for the clarification, @Alan_McMillan — As a test can you try using Roon artwork for one of these albums? Does the same issue occur for that album when doing so?

Hi @dylan
If I use the Roon artwork the problem disappears. I also noticed when doing this test that my artwork’s space was blank but Roon appeared to be searching for it as seen here:

Hi @Alan_McMillan,

Can you zip up one of these albums, including the artwork, and share it with us in a private message via a shared Dropbox link (or a link from any other service)?


Hi @dylan
I’ve sent the file you requested to using WeTransfer. At time of writing (22:49 GMT) it’s 89% transferred. Don’t know why it’s taking so long. That’s two hours it’s been running and it says it’s got another 19 minutes to go!

Alan McMillan

Hi @Alan_McMillan,

Can you send a link to the WeTransfer via a private message?

Alan, when Dylan says “send via private message” he means use the Private Message function in the Forum - not send a message via email…

To start a private message with Dylan, you have to click on his avatar icon, and press “Message”.

Thanks @Geoff_Coupe

Private message sent

An update: I’ve been using Roon this morning and I noticed that on opening the remote app on my iPad, about half the artwork in my library didn’t load…it got as far as Mahler and then it started to thin out and by the time Mozart was reached, there was nothing. I left it for a few minutes and nothing changed. I then shut down the app and restarted it. This time the artwork loaded as far as Schubert and from there the thinning out started and by Zemlinsky there was nothing. Third time lucky: another shut down and restart of the app gave me nearly everything but there are always some missing, maybe twenty overall that never come back, one of which is the Mozart opera I sent you earlier in the week. It’s as though something is choking off the artwork data stream which sometimes gives way at which point more pictures load but it doesn’t clear fully with the result that some items never get through.
Further update, later that day: I’ve noticed that the artwork builds almost instantly the app is launched. If I scroll through or tap at various points on the alphabetical list, the artwork appears on each page more and more slowly as each page comes up until eventually the artwork stops appearing at all. At that point, if I scroll through the library, virtually no artwork is visible and on my system that means maybe 1955 out of 1969 classical albums have no artwork thumbnails showing. The only way to cure this, or at least minimise it as mentioned at the beginning of this post, is to shut down the Roon remote and restart it.

Hi @dylan
Has there been any progress on this issue?

Hi @dylan
I’ve solved this one myself but it does appear to be an issue with the 1.7 update because it never happened until that was installed. Any artwork with a file size of about 200kb or larger doesn’t show up. I took all the examples I had of non-showing artwork and compressed them in Photoshop to under 175kb to be safe and every one is now showing normally in all views.

Thanks for the update, @Alan_McMillan — I’ll update the ticket we have open with our QA team investigating this and I’ll be sure to let you know what they find.

Hi @Alan_McMillan,

The team is trying to reproduce this but so far we have not had any success — Moving forward, I’m hoping you can do the following:

  • Close Roon
  • Add new artwork that is over the 200kb threshold that causes the issue for you to one of your album folders
  • Launch Roon and navigate to that album — make a note of the time you do so
  • Send us the image file and the timestamp that you tried the above

We’ll enable diagnostics and use that image for further testing.

I’ll get that done tonight @dylan