Artwork not visible on MacOS Monterey

### Roon Core Machine
Macbook Pro 2017 i5, 8Gb RAM
Mac OS Monterey
Roon 1,8 (build 884) - the most recent

Networking Gear & Setup Details

Most devices connect Wifi via Vodafone standard router
2xMuSO are via ethernet to router; MacBook Roon host is wifi to router
Remote access: 3xiPad; 2xIphone

Connected Audio Devices

All devices es over wifi
Inc 2xNaim MuSo; Apple mini;

Number of Tracks in Library

27,000+ tracks

Description of Issue

I’ve just popped Roon onto o MacBook Pro running Monterey.
Previously it was running on a NUC PC (Windows10) completely flawlessly.
I decided to crate a single AV server world - and had run Roon successfully on previous (pre-monterey) Mac OS’.

The problem is juts the one issue.
There is no artwork showing on the MacBook Pro.
Everything else works fine AND all artwork is perfectly visible on every remote (iPad and iPhone).

I ahem cleaned Roon from the machine (DB(s) in Library) and reinstalled from new down Roon download. Same symptom - no artwork visible on the MacBook Pro.

Is this a general problem on MacOS Monterey ?

Thanks for all support

No, this is not typical. However, the latest build have had quite varying results when it comes to artwork and illustrations. There are several threads on the subject.
Still, your scenario seems a bit different, so i think @support better take a look at your situation!

Many thanks Mikael - AND the Roon Support Team

Hi @support
I’m unsure whether you have this issue ?

Hi @alan_whitfield ,

Thanks for reaching out and apologies for the delay in getting back to you here, queues are bit longer from the holiday, but we’re working as quickly as we can to get back to everyone.

Can you please share a screenshot of the artwork that is missing on your Mac?

Can you please ensure that Private Relay is not turned on? This Mac feature has sometimes caused connectivity issues.

If that still doesn’t help, can you please use these instructions to access your Roon logs on the Mac and upload a set here?

Thank you!

1 Like

Hi Noris

I can confirm that Private Relay was (and is) turned off.
I’ve uploaded the logs and screenshots as requested.
My experience of Roon software over several years and Roon Core hosting platforms (Linux, several MacOS and Apple machines, Windows NUC) has been excellent. This seems an odd one - certainly by symptoms at a user level (myself and family!)

Not to muddy this thread, but I’m having a similar issue on MacOS Monterey.

RoonServer running on mac. I see artwork on my remotes (laptop, ipad, phone, etc). But I do not see artwork on any of my displays linked to a zone (for example TV via Chromecast, web display, Ropieee display, etc). This worked previously, but it’s been a while since I used the feature. So I’m not sure exactly when it stopped working.

I completely uninstalled roon from my server and did a fresh installation. Still the same, no artwork on displays. I’ve reset my network, and my machines running roon.

I’m happy to provide any details that could help with debug.

Another observation made today.
I have another Monterey machine - and when I connect the Roon “App” the the Roon Core (on the troublesome setup) all is well and artwork is visible.
It made me ponder whether disconnecting the Roon App (on the poprbelm machine) from the Roon Core (on same machine) and then explicitly reconnecting the App to the Core on the same machine would cure the problem.

Turns out I can’t do that since in Settings>Setup and “Find Roon OS” (on the problem machine) “Find” never finds the Core (I only see the Roon Roon handshake symbol waving at me.

Odd (from my perspective!)

One more observation …

I cannot connect properly via a browser on any device
Obviously i pop in the correct URL - but all I see (on any device and any browser) is a black screen with the word Roon - oh plus the question mark that takes me into Roonlabs

Perhaps these symptoms (which are problems of one sort or another) have the same root ?

More observations.
Have now run Roon as host on two Monterey machines:

  1. “Bad Macbook Pro (2017)” running latest Monterey has Anker powered Hub with connected Samsung SSD holding Music Folder
  2. “Good Macbook Air M1” (2020) running latest Monterey has Caldigit powered Hub with (same - yes the same!) connected Samsung SSD holding Music Folder

Result :
Scenario 1 above is still missing all artwork
Scenario 2 above shows all artwork

I hope this very specific observation helps.
Personally it remains v v odd!

Hi @alan_whitfield ,

Thanks for sending the logs over, it looks like Roon is having an issue getting the image file because of a Name Resolution Error, this is very strange to see though because it is getting this error when trying to connect to the same machine via localhost.

Do you have any firewalls or antivirus apps running on the affected Mac? Can you try to temporarily disable these if so and verify if that helps?

This is used for Roon Displays, you need to also start the display by clicking on Volume (bottom right) → Screen icon → Display Now. It only shows up under displays when you are on the Roon black webpage.

Find RoonOS only works for ROCK or Nucleus Cores, it does not work for Macs/Windows/regular Linux.

Are you saying that you also have RoonServer running on this same machine? If that’s the case, you can try to reinstall just the Roon GUI aspect and leave RoonServer as-is. You can reinstall Roon GUI by using these instructions:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Connect to RoonServer database

Hi Noris and many thanks for reverting.
It may be a less than insightful iteration since…

  1. Firewall is OFF and no AV s/w.
  2. Thanks for advice on browser and RoonOS vs Core - I do find some of the terminology a little ambiguous on screen at times (silly me I seldom refer to a manual) !
  3. I found a previous community thread with your kind instructions a couple of days ago. Sadly no difference when followed :frowning:

Did the difference in UX on the two Monterey instances (one on the “bad” Macbook Pro 2017 one on the “good” Macbook Air 2021) give any hints ?

Thanks again for chasing this one down !

Hi @alan_whitfield ,

Thank you for those previous details and apologies for the delay in getting back to you here, I wanted to check with the team regarding your case.

Has there been any change in behavior with the latest Roon release? We have changed the way images are loaded in this release, it may not have solved your issue, but it would be good to know this.

Earlier in the thread you mentioned this:

I’ve just popped Roon onto a MacBook Pro running Monterey.
Previously it was running on a NUC PC (Windows10) completely flawlessly.

Do you by any chance recall, did the Roon database exist on Windows, then went through the update to build 884 and it still worked properly, and then the issue started after moving the Core over (with no additional Roon update in between)?

Let us know when possible!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.