Artwork not zooming

Core Machine (Operating system/System info/Roon build number)

QNAP TS-251 running Roon Ver. 1.7 Build 667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear ProSafe 5 unmanaged switch and hardwired throughout. No wifi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Meridian 218 Zone Controller with Dell 5490 all in one and iPad as remotes.

Description Of Issue

Some album covers in the play page will not enlarge when clicked on or tapped. The page where the enlarged view should exist appears but the album cover is missing. As with quite a few problems I have had with Roon recently this is not an across the board issue. Most albums appear to be fine. It is just some of them that have this problem and I am at a loss as to discover what the difference is between one and another. All my artwork pictures are 600 x 600 pixel JPEGS and prior to the latest Roon update this issue did not exist.

Hi @Alan_McMillan,

What remote device are you using? Does this happen with all remotes?

Hi @dylan
I’ve got two remotes. An iPad and a Dell 5490 all in one PC. The problem exists on both of them.

Hi @Alan_McMillan,

Can you please share a few screenshots of what this issue looks like on your end?

Hi @noris
This is what happens when I try to zoom in on artwork:


1 Like

Hi @noris
Something else I’ve noticed that also seems to be linked to the last major update is the fact that new albums and edits to existing ones no longer appear automatically. Changes now appear only if the album concerned is rescanned and new albums only appear at all if the core is rebooted.

1 Like

Hi @Alan_McMillan,

Thanks for those additional details! Since this behavior only occurs on some albums but not all, I wonder if the directory structure could be playing a part here. If you try to create a sub-folder in your music directory and add one of the albums with missing artwork to the subfolder, does the artwork then show up?

Hi @noris
I did as you suggested with the subfolder and it made no difference. The artwork would not zoom. I don’t really understand how the directory structure could be the issue as my library has been as it is now for three years without the problem I now have. This bug has only been evident since the last Roon update. Prior to that, the artwork I am now having issues with zoomed in normally and showed up in its enlarged form.

Hi @Alan_McMillan,

Thanks for trying to restructure the folder. I asked you to try this because there have been a few reports with automatic rescan of media objects on a QNAP Core and I thought this would possibly be related.

Can I please ask that you send me one of the albums which are displaying this behavior as a private message (via Dropbox / Google Drive / etc)? I’d like to try to import the album on my end to see if I can reproduce the issue.

Hi @Alan_McMillan,

Thanks for sending those files for review. We attempted to reproduce your findings in the lab using this album, but we have been unable to do so, it is appearing properly on our end:

Can you please locate it in your albums browser -> right click -> edit -> re-identify + re-scan album and let us know if this helps?

Hi @noris
Rescanning and re-identifying the album didn’t work. However I tried resampling the artwork down from 366Kb to 145Kb in Photoshop and replacing the original with the new, smaller artwork file. That worked. I had a similar issue in the past where artwork didn’t show up at all and it was a size issue then too. Resampling down to under 175Kb or so solved the issue then as now. Not sure however why your system would different from mine in this regard.

1 Like