Arylic A50 Stuttering [Arylic firmware issue - Beta firmware available with fix]

Roon Core Machine

Intel iNuc running ROCK, hardwired to Ethernet hub hardwired to modem.

Networking Gear & Setup Details

Google Mesh Wifi

Connected Audio Devices

Many, but the one at issue is an Arylic A50 amp connected via Airplay.

Number of Tracks in Library

~10k tracks

Description of Issue

Streaming to the Arylic A50 periodically starts stuttering; I’ll get like three seconds of music, then nothing for three seconds, then repeats. Each time it’s happened I’ve removed it from Roon, done a factory reset, and reconnected everything and then it’s started working again for a couple of months. This time it’s not; I’ve been unable to fix it. It doesn’t happen when I stream directly to the A50 (via the native app), or when I connect from my phone directly to the A50 via Airplay. The only time this happens is when I direct a stream from Roon to the A50.

It also doesn’t happen when I stream to other Apple devices via Airplay from the ROCK, or any of the other Roon-ready or Roon-enabled streamers in the house.

Is this connected wirelessly or do you use Ethernet connection?

If ROCK and your network function OK with everything else in the house but the Acrylic, I would tend to assume that the Acrylic has some sort of issue? I assume it is on the latest firmware update?

Roon support will need to look at your logs to work out what is going on.

I hadn’t heard of this amp make so looked up a review. That level of distortion is normally reserved for valve (tube) amplifiers.

1 Like

Wireless. No real way to get an ethernet cable to it without running twenty feet of CAT5. There’s definitely a disconnect between the A50 and the ROCK; both devices work very well on their own and the stuttering only happens when streaming from the ROCK to the A50.

Those measurements are … interesting, but it thoroughly cracks me up when reviewers don’t talk about how an amp sounds, just measurements. I really only care about how it sounds, honestly, and I don’t hear a lot of distortion when listening. It’s my fifth tier amp, and I really only use it to drive a pair of inexpensive Klipsch speakers on my deck so I can listen to NPR quietly when working in the backyard. It suits that purpose as a cheap amp that I can leave on all the time, and stream to when I’m in the back without having to come back inside to turn on an amp. Someday when I upgrade one of my other systems I’ll swap out the amp, though.

Hi @Phil_Brady, are any of your other devices connected via WiFi or just this one? The thing that stands out the most here is the WiFi, we tend to recommend Ethernet whenever possible. I’d recommend trying to move it and test Ethernet that way, but it sounds like this only happens after a lot of time and isn’t something that would be easy to test, correct?

Hi Dylan, most of my devices are connected via Wi-Fi; I have a Bluesound Node, a Powernode, and a couple of Sonos devices connected to the ROCK core via wi-fi, and the A50 is by far the closest to a wifi hub. I can try running ethernet cable tomorrow to see if it makes a difference, though!

No change; same stuttering even hardwired.

The same exact thing happens to me too. I have two Arylic A50 devices and both started to behave exactly as the OP described. Both are connected via Ethernet, just like the Roon Core.

The same thing on my side, before the last build everything was working perfectly and since this update my two Arylics (Up2stream) only work for 2 seconds and then switch off continuously.

1 Like

Same here with Arylic S10 (Raokit Technology) switch off continuously [Stuttering]
i tried it roon server roon core on pc same. Stuttering

Everyone who has the issue, looks like it has been introduced by Arylic in their latest firmware update. They released a Beta firmware that can downloaded here: New update causing iTunes Airplay Issues - #31 by zpl1025 - DIY Product Questions - Arylic Forum

I tried it and i solved my issue!


62 / 5000

Résultats de traduction

Thank you very much !!, it works again with beta firmware.

1 Like