ASIO Support for Luxman DA-06 Stopped Working After 1.2 Upgrade


Congrats on the release of version 1.2. Unfortunately for me I have not been able to enjoy it yes because my Luxman DA-06 ASIO source stopped working.

I have a temp workaround for low res playback with my WASAPI driver…

Could you take a look at this?


Hello @cmonache,

Can you please described in more details what exactly is happening when you are trying to playback to ASIO zone ? Also would you mind to describe your setup ?


Sure, sorry my general description did not have a lot of information :grinning:

I am running a Windows 10 Pro connected via USB to my Luxman DA-06.
I can set up the ASIO under Audio Setup and associated preferences. I can also select as one of my
Zones for playback.

When I return to the main menu and start to play a track, it loads the song but never locks in the USB signal it seems. I cannot get a signal lock on the DAC. With WASAPI I can. It appears to try to play the track, the music bars next to the song name in the queue start bounce but the song never plays nor does the track time in the bottom bar proceed.

Thanks for detailed explanation @cmonache, at this point I would like to check the Roon logs - they should tell us more regarding the issue. I’ll contact you shortly via PM with more details.

Hey @cmonache, I just had a look at the logs.

It looks like your DAC’s driver is sending Roon a “device not present” message when we try to start playback.

Looking through your logs, I can see a second bug in the ASIO driver–though we know that this DAC supports native DSD, it does not implement the Native DSD support interface according to the spec. I think this bug may be confusing some of the new format probing code in 1.2.

After studying the differences in the log files from 1.1 to 1.2 with this device, I see a slight difference in the sequence of events. Both sequences are within spec, but maybe this driver is pickier than it needs to be. There’s no way to be 100% sure that this was the cause of your problem, but it is the best guess we can make with the information in front of us.

That workaround will be in the next build. Let us know how it goes. If that doesn’t fix it, we’ll take another run at it then. In the mean time, we’ll reach out to LUXMAN and see if they want to provide a device to us to work with. It’s much more expedient for us to work around driver/device-specific issues when we have access to the gear. Looking through our support history, I see that we’ve had a few problems with this one–it is clearly unlike the others in some way.

Thanks for the feedback, please let me know if you need help with testing or access to my environment. I have also contacted Luxman to ask about their driver

Luxman says they are shipping a DAC out to us next week.

If the upcoming bugfix release doesn’t fix you, I’m confident we’ll be able to debug this in-house once the unit gets here.

Build 128 is out. Let us know how it goes.


Installed Build 128 after work. Thanks for the quick turn around.
Unfortunately did not work.

Do you want me to send you new log file?


I’m sorry to hear that :anguished:

Sure, we can take another look. You can use the same support ID as before.

Okay new log sent. Thanks

Was wondering if there was any progress on the Luxman fix. Obviously only one product causing this problem but heading into the Golden Week Holiday here in Japan and would love to have my Luxman up and running again with Roon. :grinning:

Our unit should be here next week. Hoping for a quick fix once it’s here!

@cmonache, the DAC arrived today.

Unfortunately, I’m not seeing the problems that you’re seeing.

What I did was:

  • Take it out of the box and plug it into power + USB
  • Power it on, and select USB input on the front panel
  • Install the current LUXMAN driver on Windows 10
  • Enable the LUXMAN ASIO driver in Roon with default settings.
  • Play a bunch of different content formats, including 44.1k, 96k, 192k, 384k, DSD64, DSD128

Is there any advice you can give me that might help me recreate the issue? I have the same OS, device, and software, so in principle it should be possible.

In your logs from build 128, I see that the driver is returning a “DAC Not Present” error to Roon when you attempt playback. This sometimes means that things have devolved into a bad state in the hardware or driver. Sometimes power-cycling everything fixes that sort of thing. It sometimes can indicate that something else is using the device at the time, too. Just things to check.

I’m sure we’ll get to the bottom of this. Let me know what you think.


First of all, thanks for all the extra effort trying to figure this out.

Out of interest could you confirm something for me? I have had many DACs over the years connect to a PC or CD player, etc.
When you did the setups below and before you played back in Roon did the Luxman lock in a signal?

This is how it is behaving for me:

  1. Boot up the PC, | will get a quick Windows message and the DAC relay will click and it will lock into 48kHz. then the lock is released
  2. Currently nothing is soon the display of the Luxman and no software loaded on the PC.

Is your Luxman always showing a locked signal with the PC or does the lock click in an out when you are playing music.

The only software difference I can think of is that I am running my Window 10 on a Mac mini and I am seeing one Bluetooth USB Host Controller device in error mode but all the other drivers seem okay.

Luxman Japan probably on holiday this week for the Golden Week holiday. Will contact them too… from a hardware perspective.


Okay more head scratching.

I switched to a second MacMini (Same model and Spec) also running windows 10.
Not sure I have the Roon terminology correct but this would be acting as a remote node connecting back to the Roon Core.
I installed Luxman driver here, setup the ASIO driver in Roon and it is working.

Should I send another log?

I guess the good this is the DAC is working… Both these PCs are bare installs…

It almost feels like the Luxman driver on the Core Machine is having a problem and I cannot get a clean uninstall and reinstall?


When I start up, the DAC is unlocked. When I start playback, it locks. When I stop playback + release the device (Ctrl-T in Roon), it unlocks immediately.

Maybe you have the DAC set up as a default device in Windows, and accessing it via ASIO and WDM (Windows native driver) at the same time is conflicting?


Okay, not sure why it is happening but think I have figured out a pattern. If I use the Luxman Audio Player, which is based on the Luxman ASIO driver I can playback files. Please see the attached JPEG.

If I stop playing in the Luxman Audio Player and load Roon and try to play I do not get any sound… and Roon just stops. What is interesting is in this state if I go back to the Luxman Audio Player then I am getting the error you are seeing “Playback Device is not available” and now I can now longer play music in the Luxman Audio Player.

Now for what is really interesting I have figured out how to “trick” Roon into working with the Luxman ASIO driver.

  1. Have all applications shut down.
  2. Load the Luxman Audio Player
  3. Load a few songs and start play back
  4. While the Luxman Audio Player is running, load Roon
  5. Stop play back in the Luxman Audio Player
  6. Play back a song in Roon… It works!
  7. Stop playing in Roon
  8. Start playback in Luxman Audio player… it also still works.

It seems like if the ASIO driver is operating when I load Roon it works. If I load Roon without the Audio driver working it gets stuck in a playback device not available until Roon Core is closed.

I am not sure why Core and the remote node are different. I do know that it was working before the upgrade to 1.2 but still feels like the Luxman ASIO driver is a bit quirky and I wonder if the uninstall and reinstall has messed things up a bit on the Core Machine?



It seems that having the Luxman set to the “default” Windows sound device was causing the problem. As soon as I removed the Luxman default status it appears that Roon is working with the Luxman again.

Will try some more today and tomorrow and let you know.