Assistance connecting Bluesound Node via Roon Ready

Roon Core Machine

Windows 10, 4th gen i7, 8gb RAM,

Networking Gear & Setup Details

I have a Netgear Nighthawk router with four ethernet ports. I have a Bluesound Node connected to the router and a this laptop (core) connected to the router.

Connected Audio Devices

I have a Bluesound Node (app 3.18.0) connected to the router via ethernet.

Number of Tracks in Library

Music library is 1,000 tracks

Description of Issue

I just signed up for Roon. I have the core installed on my laptop, which is connected to the router via ethernet, and I have a Bluesound Node hooked up via ethernet to the same router.

The Roon software recognizes the Node but it is not recognized as Roon Ready and connects via AirPlay rather than over the network.

I don’t know if this is a Bluesound problem or my Roon configuration.

Thank you in advance for your help.

Welcome to the community, @anon15900052!

Open the BluOS app and check that you have the latest update.

Thank you for your reply.

I have BluOS 3.18.7, which was released one month ago. This is the latest version.

Do you think it is a Bluesound issue?

Roon should recognize the Bluesound being on the same network? Is it a networking issue?

Thank you.

I don’t have a Bluesound device, but are you able to turn off the Node’s WiFi and see if it is recognized on the network? Also, have you rebooted all devices, including the router, Core laptop/Roon app, and the Node itself?

This os the app… have you updated the firmware for the players? I’m away fro home, so can’t be more precise. Also, try unplugging and reconnecting the players as this sometimes sorts out niggles.

The node works fine as a roon ready device. Try unplugging the ethernet and see if it is discovered on wireless.

I didn’t restart the router or Bluesound, but late last night the laptop restarted and saw the Bluesound Node as Roon Ready. According to the Bluesound forums, having the Node connected via ethernet shuts off Wi-Fi. I didn’t connect the Node to Wi-Fi to begin with so I don’t know how it would connect to my wireless network. I don’t really understand Airplay being a PC user but it must be like Bluetooth and was connecting via Airplay. I attached a screenshot; the Airplay connection is still present connection with the Node, so I had to manually disable that and enable the Roon Ready option.

Anyway thank you all for your help with what turned out to be a rather simple problem. Looking forward to using Roon and all that it has to offer.

3 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.