Astell & Kern sp 200T set up with Roon

I have an Astell & Kern sp 2000t
It says on the device its Roon ready?
Trying to connect it but I have a Mac so the proposed downloads are all android or windows???

You need to install on Mac application called Android Transfer Tool. Search YT for tutorials.

Thanks, I have and the mack still does not see the device in finder to transfer to? The app opens but that it. thanks for responding, I’m lost here and frustrated it should be more straight forward, my palm pilot was easier a thousand years ago…

Any help?

What you trying to do. A&K DAPs don’t need anything installed to get Roon Ready it’s not an app its built into the OS like other endpoints. The Roon app doesn’t work for this. It should be part of the over the air firmware upgrade for the device. Does this model not allow OTA updates?

You just turn it on in the UI and add it as you would any other endpoint.

1 Like

Thanks, I see a Roon Ready toggle switch , turn it on but never see how to sign into Roon again or see it in services?

thanks it worked

You are already running Roon core on a pc? Roon Ready is just a Roon client it’s not the server you can’t run or use it without Roon core server running on other hardware. You don’t need to do anything but turn it on in the UI and it will show up as a device in Audio settings in Roons main app. Enable it. You don’t sign in to anything. You don’t use the Roon app on it as it’s not whitelisted. It’s not supposed to operate as a controller but as an endpoint only use the remotes on pc phone etc to control it.

Thanks again for you time I really appreciate it.

Yes I run Roon on a Nucleus that connects to a MacBookPro.

The AK is running the latest update. In the UI there is a toggle with in settings for Roon which I have switched on. So I must be missing something in understanding how I get into my Roon files ??

Do I need to have the AK plugged into the Mac?

It doesn’t see your Roon files. It’s an active endpoint you play to it like any other Roon zone. On you Mac open up Roon look under Settings/Audio you should see it there under Roon Ready devices. Enable it, you can then choose it in Roons zone picker and play to it as you do any other device. As I have said you don’t use anything on the A&K at all Roon is push system it pushes audio to endpoints. It plays over WiFi to your A&K.

Ok that’s my issue it does not show in Roon Ready in setting. I tried selecting it where you select devices but it won’t activate after I set it up, maybe in the wrong section?

the selections are
Roon tested
connected to the Roon Core and other

it set up under connected to core, seems I can do it another section at least I don’t know how ?

Unplug it from the Mac, that’s what it’s showing up there as it’s in DAC mode. Is it on your wireless network? Is that wireless network on the same subnet as your nucleus? How do you control Roon normally? From mac, phone or tablet? It should show up under Roon Ready if it’s not connected to your mac and connected to your network via wireless. That’s the whole point of it being on the DAP. If it’s not showing up. Restart it or you have network issues blocking Roon from seeing it. You don’t need it connected to the Mac in that mode the mac is streaming and the A&K is just a DAC. Which is fine but its not using the Roon Ready feature in that mode.

My nucleus is plugged into my modem/router direct via Ethernet cable.

Mac, iPhone , iPad all wireless controls my roon and my meridian system

In audio set up I can identify the phone or Mac or tablet

That’s what I was expecting

The audio set up shows AK as an equipment option

However I can select it it stays greyed out. I’m stumped

Maybe it’s in the wrong section of the audio option?

Btw it’s very kind of you to take this time, it’s driving me crazy as I set up the entire system 1,2,3 no issues it saw everything

Direct Ethernet connected roon, even the Wi-Fi I one gigabit speed so I can’t understand what I’m doing wrong


Reboot the A&K, Roon core and try it again. When I had my Kann Alpha it didn’t work straight away I turned on the Roon Ready mode and then ended up rebooting it for Roon to see it. I got rid of it in the end as as a Roon endpoint it was unreliable network wise. I put this down to the older WiFi the Kann uses but it might be just generic to all the range.

Thanks I’ll try that

Just to be sure, rebooting the AK not reset correct?

Yes just a restart.

Will do thx