ASUS Tinker Board as Endpoint


(Raymond Tayse) #1

I have configured my Asus Tinker Board as a Roon Endpoint.

The reason I bought both is to see if the Asus Tinker Board with external WiFi antenna would be a better choice for a wireless endpoint.

My first test was hooking it up to my Schiit Modi 2U / Magni 2U. Wow, this sounds like crap at the moment. You know the sound you get when a cell phone is close to speakers when a phone call comes in; that is a constant. So I figured, let me try it on my Leckerton real fast to see if I get the same. Nope, crystal clear music as I was expecting.

I tried 4 different USB cables to the Leckerton (including the PYST USB cable), and they all sound the same. Pretty crappy.

I am streaming Tidal 16/44.1 to the device is only using ~200k on the wireless and my Asus router is showing a ~50 Mbps wireless connection to the Asus Tinker Board at the moment, so I cannot believe it is a bandwidth issue. I also used WiFi analyzer and I am on a clear channel (no other carriers under or near it). Also, it works fine with the Leckerton.

update I tried hardwired ethernet and I have the exact same problem. I have read around that the Pi 3 had simular problems with the ALSA buffer and they made a change in /etc/modprobe.d/alsa-base.conf (snd-usb-audio nrpacks=1). Unfortunately for me, the Tinker Board does not have a file in that directory.

Maybe I need a better shielded USB cable for the Modi 2U.

Any suggestions are appreciated.

-Ray


(Fernando Fuentes) #2

Ray,

What OS you have running on your Thinker board?
I dont think you are having USB cable issues.


(Raymond Tayse) #3

I tried the latest ASUS distrobution of Debian, DietPi, and Armbian. All have the same issue. It has to be a USB buffer issue.

I tried modifying PulseAudio Fragments using the following:

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Setting_the_default_fragment_number_and_buffer_size_in_PulseAudio

No luck with that either.

I have purchased an RCA bulkhead and I am going to hook up the S/PDIF connection and see if that addresses the issue. Some DAC’s just do not universally play well with USB; it looks like Schiit is one of those.

-Ray


(Fernando Fuentes) #4

@Raymond_Tayse try installing MoodeAudio and report back . also try the USB UAC2 Fix, I had to enable it for my Schiit Bifrost.


(Fernando Fuentes) #5

Also for got to mention that I run Roon-Bridge with MoodeAudiop so no worries there!

http://moodeaudio.org/


(Raymond Tayse) #6

Are you using that with the Tinker Board?

I would hate to pay for something that does not support the board.


(Fernando Fuentes) #7

Crap, The newer version is payed… Ok I can send you the earlier open versions which where free.
I will link you in a bit.

Is based on raspian, If you have all of those going just fine, I am sure it will work with no issues.


(Raymond Tayse) #8

Well that seemed to be a waste of $10, I cannot even get this image to boot.


(Fernando Fuentes) #9

I was going to link you to the free image! :flushed:


(Raymond Tayse) #10

It was $10, not a big deal. Just disappointed.

I wrote the image. Connected everything. The only thing that lights up is my Logitech G900 mouse. The no video, keyboard not lit up, ethernet not lit up, nothing.

I am not familiar enough with linux to understand how to apply The USB UAC2 fix to the ASUS distribution. My knowledge is based on what I can Google heh. So if someone else has not done it, I am usually stuck on Linux.


(Fernando Fuentes) #11

Moodeaudio has no video. It works via its web ui… There is No ethernet?


(Raymond Tayse) #12

No, none of less on the NIC are lighting up. Can I preconfigured wireless? I could try that.


(Fernando Fuentes) #13

If wireless is working you should see a new SSID broadcasting called moodeaudio, By default the wireless goes in AP mode so you can connect to it and configure it that ways… Do you see one?


(Fernando Fuentes) #14

So I was able to track the fix for UAC. Try:

Add dwc_otg.fiq_fsm_mask=0x3 to the beginning of line in /boot/cmdline.txt

You can do this on any of your Raspbery Debian base distro.


(Raymond Tayse) #15

Excellent. Reflashing and will try.


(Raymond Tayse) #16

Ok,

I have been racking my brains for 3 days trying to get the USB audio to my Schiit DAC’s to work properly with the Tinker Board. I was literally just moments away from throwing this thing through the wall when I came across a thread about Volumio.

I have tried every other OS you can think of with the Tinker Board. The ASUS distribution, Armbian, DietPi, MoodeAudio, etc… Every single one has problems with connecting to my Schiit DAC’s via USB (Modi 2 Uber, Modi 2 Multibit, and Bifrost Multibit). Basically it sounded like computer speakers when you had an old cell phone next to them and a phone call would come in. Just wobbly and like data was missing.

I tried adjusting the PulseAudio Fragments, I tried several combinations of dwc_otg configurations including:

dwc_otg.fiq.lpm_enable=0
dwc_otg.fiq_enable=1
dwc_otg.fiq_fsm_enable=1
dwc_otg.fiq_fsm_mask=0x3
dwc_otg.fiq_split_enable=0
dwc_otg.sped=1

I even purchase a Female RCA Bulkhead connection so that I could solder up the S/PDIF pin on the board to get audio. The most frusterating thing was that it always worked perfectly on my Leckerton UHA-6S MKII and my Oppo HA-2SE, but never with my Schiit DAC’s. I tried different USB cables, ferrite chokes, and even one of those AudioQuest JitterBugs. I have spent far more time, effort, and money over the last 4 days trying to get this to work…

So came across the thread while researching the dwc_otg.fiq_split_enable=0 functionality some more. Not sure exactly how I got there. It is pretty late at night and I thought, what the hell, I’ll try this last build and if it does not work I may stomp on this stupid board.

Well, it works PERFECTLY! Exactly as it should without any modifications needed. It does not matter what cable I use, ferrite choke or not, JitterBug or not; it just works properly with all of my DAC’s.

My only complaint, I wish they had the option to have Roon Endpoint installed from the awesome web interface. I did not find it hard to manually install through the console. It would just be nice.

Raymond Tayse


(Fernando Fuentes) #17

YAY!
I am glad u didn’t throw it against ur wall!
:slight_smile:

Enjoy some awesome music. And yes Volumio is neat!


(Igor Pecovnik) #18

Armbian provides a modern kernel for Tinkerboard, which is in a much better shape. There are also realtime RT kernels for Tinkerboard available: https://twitter.com/armbian/status/926718590878961664 Perfect for Audio.

https://www.armbian.com/tinkerboard/ -> “MAINLINE” = kernel 4.13.11 at the moment.

Offical kernel or any other images does not provide that.


#19

Thanks Igor. What are the advantages of the RT kernel for something like roon?


#20

There aren’t any