Asustor Playback failed codec error

Roon Core Machine

Asustor AS5304T, Gemini Lake Celuron J4105 Quad Core, 4GB DDR4-2400 RAM

Networking Gear & Setup Details

Multiple Eero 6 Pro mesh Wifi Routers. On Wifi

Connected Audio Devices

Sonos system speakers and amp, Marantz AV7704. Connect with Airplay2

Number of Tracks in Library

8500 tracks

Description of Issue

Getting playback failed because required codec is not available. Problem is for almost the entire library and just began in the past couple of weeks.

Welcome to the forum Michael!

The Roon-beehive would certainly like to help you out, but it’ll help tremendously if you’d kindly mention what the operating system is.

ADM. Asustor Data Master

I’m not a NAS guy, but maybe that bit of info helps…
Good luck!

Hi @Michael_Vernon,
Roon Server on Asustor devices rely on FFmpeg, which will be automatically installed in the App Central when Roon Server is installed.

The FFmpeg App in the Asustor App Central is not maintained by me and I did not notice any changes in that dependency so far.
As a second option, I’ve added the option to provide your own ffmpeg binary in the RoonOnNAS/bin folder. This was previously not required to do, as everything seemed to work well with the App Central version of FFmpeg.
I can’t check this at the moment, as I am still with my family for Christmas. But I will check it, when I am back home.

In case you’d like to try to provide your own FFmpeg binary, you’ll need to download the version for the amd64 platform. The most common website to download FFmpeg is JohnVanSickle.

It is a tar.xz archive, that needs to be extracted first. Depending on your utility to uncompress the file, you might need to extract it twice.
In the end you should see several files, but you only need to put FFmpeg into the RoonOnNAS/bin directory.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.