At Some Point In Recent Months (Likely During A New Version? ) Roon Is No Longer Seeing My NAS

I’ve been streaming a lot of late, and was working too many hours to do listen nearly as much as I would have wished. Thankfully that’s changed for the better. However, I suddenly realized that I cannot access the music library on my NAS. I’ve verified that all is well with the network and the NAS. Roon just stopped being able to access it. How do I fix this?

Thanks for any help.

You’ve given absolutely no information for anyone to help you.

Fill in this template about your system.
I’ve moved your post to the support area.

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

One possibility is that the IP address of your NAS has changed

ged_hickman1 said:

You’ve given absolutely no information for anyone to help you.

Fill in this template about your system.
I’ve moved your post to the support area.

Roon Core Machine - Small Green Computer Sonic Transporter

Networking Gear & Setup Details - Sonore System Optique streaming system - MHDT Labs Orchid DAC - Synology DS713+ NAS

Connected Audio Devices - Conrad Johnson CT5 preamp, Art Audio carissa Signature amplifier

Number of Tracks in Library - 2000 cd’s

Description of Issue - all of a sudden, I cannot access the music library on my NAS via Roon, when it was always possible before.

Please note that everything in the system has been tested and verified except for the Roon software as it relates to connecting to my NAS. I can stream in both Qobuz and Tidal with no issues.

Post a screenshot of your Nas connection in roon. Roon, settings, storage.

will post the requested screenshot as soon as I can find a way to do a screenshot on an iPad and transfer it to where I can import it to here.

You don’t need to transfer the screenshot, open this page on the iPad browser.
Screenshots on iPad

Apologies for the delay. I had an unexpected hospital stay due to an emergency appendectomy.

here is the picture of the requested screen:


Oh no! I hope you’re feeling better!

Your screenshot definitely implies that the storage location has changed like @Norman_Spector suggested. Are you able to find it when you click add folder under settings>storage?


Thanks for the kind words, I’m finally starting to do much better. It has taken a while, though. But listening to music always helps.

Under “add folder” it brings up a different location -

1 Like

The IP address of the Nas has changed. Instead of using an IP address you should use its name.
As an example \bob-nas\music

1 Like

Problem solved


Hi @Jeff_Corbin,

Did you add the location you found? Has your access to your NAS been restored?


Sorry for the delay again in responding. I ended up back in the hospital due to an infection related to my emergency appendectomy. I’m praying there are no more issues to come.

After reading your solutions, I tried to add a new folder in Room, under settings, and then storage. The old folder shows \\music, which, of course is now not available due to the IP address having changed on the network. I tried creating a new folder using \192.168. 50.227/music, that being the correct IP address, but I get the message "invalid path specified? I don’t understand why, I am exactly copying the format of the old folder that it can no longer locate?

Anyone? I have no idea what I need to do now.

You seem to be using a totally different network from your original setup. Have you changed your router or its settings?

The original address ( would be an address in the range of addresses of 192.168.1.x, where x would be a value between 1 and 254. Now you are saying that the new address is in the range of 192.168.50.x - this is a completely new, and different network, from the original. I thought you had originally said the new address was

You also seem to have quoted the address using a forward slash (/music) instead of a backward slash (\music), so the correct address may be \\\music (if all you are using a new set of network addresses) or \\\music (if you are still on your original network).

Also, as your screenshot says, you should really edit the existing folder address, rather than create a new folder. Click the “3 dots” menu next to the existing folder address in Roon to access the edit function.

Finally, as @ged_hickman1 suggested, you should use the network name of your NAS instead of its network address if possible. That way, even if your router gives a new address to your NAS, it will continue to be accessible by Roon without the need to edit the folder’s network address in Roon.



Please try what Geoff suggested. It looks like you went from a Netgear (or similar) to an Asus router and things just got mixed up. After that, the switching for network addresses was formatted incorrectly. If you can open an instance of Windows explorer and navigate to \\\music successfully, then Roon will be able to do the same.


1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.