Audio analysis completed, but I'm still getting stuttering

Audio analysis completed, but I’m still getting stuttering. But with the QNAP TVS-471 nowhere as bad as I was getting with the previous low powered NAS.

I suspect the stuttering is linked to the audio analysis. Maybe switching off all audio analysis will fix it.

Hi once audio analysis has completed it is only run again on demand, or for new file imports … so I don’t think switching it off will make a difference.

I’m wondering if there is a bottleneck in the network. Can you please describe your setup, in detail, as seen here. The more specific you can be, the better.

Also someone one here reported issues when they “upgraded” their network switch reverting to the cheaper version fixed the problem. So if you have a spare switch or can borrow on that might yield results.

This skipping and stuttering problem was said to be caused by under powered NAS drives. I bought a powerful Qnap TVS 471 and set it up as advised by Roon and I still get stutters, but no where as bad as it used to be. It is playable now.

It is a software problem which Roon needs to fix.

Hello @Peter_D_Castro,

  1. Do you use your NAS as a core?
  2. What are the specs of this device?
  3. How big is your library?
  4. Where Roon DB is located on the spinning disk or SSD?

It’s a Qnap TVS 471 configured as recommended by Roon. SSD contains the qpkg. Two HDDs in RAID containing the music files. Library is only 10k tracks, this should not be an issue. Maybe I need to uninstall Roon and install it on the SSD.

[quote=“Peter_D_Castro, post:39, topic:10909”]install it on the SSD.

This should see an immediate improvement over Roon Core on a spinning disk.

Edit: I merged posts from the other thread in here as they seem to be the same issue.

Hi Peter,
can you be more specific on your setup? I understand the SSD has been selected as the destination for the qpkg installation. Where did you create the RoonServer shared folder (also on the SSD?), your music files are on spinning disks?
What is the situation when you experience the stuttering? Are you playing to multiple zones simultaneously? Does it occur when you play especially large (or high res) tracks? Could it be related to high network traffic, for example when you copy large files over the network connection while Roon is playing?

RoonServer is also on SSD. Music files on spinning disks. I’m playing standard 16 bit files. System Output is enabled and Bryston BDP-1 enabled. All computers, except for Roon computer, are usually turned off when I listen to music. There is no high network traffic. Music listening is a focused activity. Nothing else going on.

To be honest, I doubt that the spinning disks are the cause of it.
I still suspect that this is some kind of network related. Is your Bryston BDP-1 also connected on the same network switch?
If you have a spare ethernet port on your QNAP, you could try to assign a static IP to one unused QNAP ethernet port and also assign a static IP to the Bryston. Then connect the ethernet cable of the Bryston (if possible) directly to your this QNAP ethernet port.
The static IP adresses can be chosen within your regular IP range (for example: 192.168.0.xx).

How is your music storage set up in the Roon configuration? As a local folder?

EDIT: You could also try (if doable) to connect the bryston via USB directly to the QNAP to check if the stuttering still occurs.

For clarity, I’m assuming the folk at Roon didn’t actually tell you to go out and buy a Qnap TVS 471 and that you’ve merely followed their configuration suggestions, which would include:

  • 8GB ram
  • Roon database on SSD

If you’ve both of the above ticked, I’d check the network configuration for performance/ stability issues.

So you’re saying that instead of connecting the Bryston ethernet cable to the router I connect it to the Qnap NAS?

It is just an idea for testing purposes, to check if there might be something interferring in your regular network.
Alternatively you can test if the stuttering also happens when you connect the Bryston via USB directly to your QNAP.

I think I’ve fixed it. I uninstalled Roon, including database and settings from the laptop and reinstalled the program as a Remote, with the Roon Core, etc, being installed on the SSD on the NAS. This effectively transforms the laptop, or similar, to only perform as a remote control, not as a music server.

Fast Audio Analysis and file importing worked without problems; and music is not stuttering. It did not take long for the Roon database to be re-established on the SSD, with the music files being Watched as a Local Folder.

The problem arises when Roon is installed on an Notebook/Laptop which are wifi remotes. Putting it on the NAS put the application on a connection wired to the music system via ethernet. While it was on the laptop it was operating as a wifi server application. Wifi, of course, is not as fast as ethernet.

Instructions should specify to install Roon on a NAS drive or component which is wired to the music system.

On QNAP the address for Local Folder is /share/music.