Audio Analysis Runs Forever after 1.6 to 1.7 Upgrade

Windows 10 Pro x64 version 1909 on separate Core and Client PCs / Core on Lenovo M93P Tiny i5 headless server, Client on homebuilt Intel i5 PC / Roon 1.7 Build 500 and 505

WiFi 802.11 AC 5 GHz from Client to Core via Asus AC66R

After doing the upgrade from 1.6 to 1.7 build 500 and then to 505, the Client, under Settings -> Library, always shows the Audio Analysis with the spinning circle and as still analyzing 0/1. It’s been several days now, and I’ve tried restarting the core and the client PCs and reinstalling Roon 1.7 build 505 on the client without any change. I only have about 12,000 tracks, all but one of them seem to have finished analysis in the first few hours, and neither the core or the client seem to be doing any analysis now. Their logs seem to confirm that. The logs also fail to identify what track might be causing the problem.

Fortunately this doesn’t seem to affect Roon’s ability to play music.

Hi @Peter_Gettinger,

Can you please send me a copy of your logs by using these instructions? The best way to them over to me would be via Dropbox / Google Drive. Thanks!

The Client and Server Logs and a screen shot are on Microsoft Onedrive at!Aqmt4s9Xk4YAgpA8iAohOakurbvTKw?e=4gwfRR

The Server Logs cover several months and started on 1.6.
The Client Logs only cover since I reinstalled 1.7 build 505.
The screen shot is from 2 days after I captured the logs, but is identical to what I was seeing during the period of logging.

Rather than look at the whole mess, start looking about 1:55 PM on 11/27. I had shut down the client just before that, but left the server running for a few minutes by itself, then restarted the client at 1:55 and left both running for a while.

Thanks for your attention. I hope you had a good holiday.

@noris Should I have tagged my reply with the link to the log files to you? I’m still trying to learn how to use the forums properly. There’s no rush on looking at the log files, I’d just like to confirm you can get them OK.

Hi @Peter_Gettinger,

I appreciate your patience until your case reached my queue again. As to answer your first question, yes, generally speaking tagging helps in some cases, but we do track the threads we reply to, so tagging is optional but appreciated.

As for the log files, I’m seeing Roon is stuck scanning on the following file:
\Home-Dad2\Music\Scott\Burkhard Dallwitz\The Truman Show\08 Romance-Larghetto.mp3

Can I please request that you:

  1. Move this file out of your watched storage location (do not delete)
  2. Reboot the Core
  3. Verify if the issue went away
  4. If it did go away, please upload this file to your Onedrive and send it to me for analysis


@noris Removing the file from the watched storage location seems to have fixed the problem. I’ve added that mp3 file and two screen shots from afterwards to my OneDrive share. On listening to that mp3 file, it seems badly corrupted, so I guess it’s not too surprising Roon got stuck. (Though I fully support the concept that nothing the user does should be able to cause a failure.)

In the screen shots notice that Roon now wants me to clean up a deleted file. I presume that’s the same one it had previously tried to process and you had me move. However, I must note in the spirit of better usability, that Roon should have a way of displaying some useful info about the entries it proposes to delete. After all, the underlying cause might be a hardware or system problem that would be hard to identify or correct without knowing what file(s) are involved.

Anyway, thanks for identifying the file involved and providing a good detour.

Hi @Peter_Gettinger,

Glad to hear that removing that file resolved this issue.

I can get it over to QA for closer inspection, but I just checked the onedrive link you previously sent and I am not seeing the file, can you please re-upload it?

This would be a fantastic feature request, I suggest that you post it to the feature request section of your site.


@noris Sorry, I don’t know what happened to the mp3 file, but I’ve uploaded it again and it looks like it’s there now, along with the two screen shots from yesterday. The mp3 corruption starts about 50 seconds in and comes and goes after that.

Thanks again. I’ll mark your previous reply that identified the problem file and workaround as the solution.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.