Audio Device not found after SONOS Firmware Update

• Version Roon - Roon 1.3 (Build 276) , on Synology DS 1815 256 GB SSD and 8 MB RAM
• Desktop - iMac (Retina 5K, 27", Late 2015), 32 gb RAM, SSD 1 TB drive
• Iphone – Iphone X 256 GB
• Sonos – Play:3 via Wifi
• HifiBerry AMP via LAN
• Router: Fritzbox 6490 & 1750 as AccessPoint in Mesh-Mode

Issues @support
• After a Firmware update to SONOS 8.2 (Build 39247040c) my Play:3 does not show at the Audio Devices.
It worked before with SONOS Firmware 7.x very well.
The Sonos App on Iphone, Ipad and Mac is connected to Play:3 without Problems.
Any known problems with the SONOS Fimware 8.2 ?

Thanx for your assistance.

Hi @Alexander_Halm ----- Thank you for the report and sorry for the slow response here.

I wanted to touch base to see how things were going. If you are still experiencing this issue with the mentioned Sonos device, please drop the support team a “flag” (i.e @support) in your follow up and a team member will be glad to help!

Looking forward to your update!

@Alexander_Halm ---- I saw you updated your original post to include a flag for the support team, so my assumption is that you are still experiencing this issue with the Play:3.

Moving forward, I checked the SONOS section of the community site to see if anyone else was reporting issue after taking the latest firmware update and I am not seeing any other related posts. My sense is that if this was a widespread issue, we would be hearing more about it as we have many users who are implementing various Sonos based endpoints in their setups.

In light of the above I would like to have you run a few tests to see if we can isolate some variables here to help determine where the issue could be stemming from. Please see below.

  • Could you please test with thePlay: 3 mounted directly to the Fritzbox 6490 router and confirm if the application identifies the unit.

  • Please try testing with the mentioned repeater (i.e Fritz WLAN Repeater 1750E) temporarily disabled and confirm how things respond in regard to the mentioned endpoint. It is important to point out that we have seen issues pop up with these types of devices in the past, which is why we recommend the use of a mesh network configuration by companies like Orbi and Eero. Our CTO Brian goes into further detail about the limitations of these type of products (i.e “extenders”, “repeaters”, etc) here.



Hi Eric,
thanx for your support.

I tested the SONOS Play:3 direct with a networkcable connected to the router:
Same issue. I tried with my Iphone and my Mac. The Sonos App still works.

First time i connected the SONOS Speaker to my network, it appeared instantly in the device list.


Hi @Alexander_Halm ----- Thank you for touching base and sharing the results of the proposed test. Very appreciated!

Moving forward, during the mentioned test run did you also happen to confirm how things responded with the repeater temporarily removed from the chain of communication?


@support Any updates on this? Just did a fresh install of Roon Core on my Synology NAS and also don’t see SONOS devices.

My setup
Roon Core: Roon 1.3 (Build 276) on Synology DS 716+ with 8 GB RAM
Roon Client: MacBook Pro (13-inch, 2016)
Sonos: Version 8.2.2 on PLAY:5 & PLAYBAR connected via Bridge
RP3 with Allo Digione running Roon Bridge
Router: Netgear Orbi

Roon Core -> Ethernet -> Orbi
RP3 with Allo Digione -> Ethernet -> Orbi
Roon Client -> WiFi

Some data points

  • Allo Digione shows up just fine
  • If I run a Roon Core directly on my laptop, SONOS devices show up and everything works as expected.
  • I am able to see and stream to SONOS devices from my NAS via Synology’s DS Audio app (implying that my network layout should be ok).


So I managed to figure this out, although it doesn’t feel like a good long-term solution. If I disable Open vSwitch for the network interface connected to my LAN, SONOS (and Airplay) endpoints show up again.

Synology Control Panel -> Network -> Network Interface, select your interface, then Manage -> Open VSwitch Settings -> Disable

I should also add that Open vSwitch was enabled by default on my fairly stock setup running DSM 6.1.4-15217 Update 3 install. Perhaps a result of installing Docker?

No time to dig deeper on this right now, but would be interested in a better solution, if one exists.

Thank you very much.
Disabling the OpenvSwitch Option in the network interface did work.
Now my Sonos device works with Roon again.