Audio Device not loading [Resolved]

I have been Roon user since it came out. I now have 2 lifetime memberships. I have a stable installation at home with a dedicated PC going to a microRendu via the network with no issues. I run the other at the office, on a simple PC connected via USB to a DAC (HoloAudio Spring). This system has been working well for about a month. This week it said that it can’t find an audio device. When I go to the page to choose the device, it shows 4 devices - system, 2 related to the onboard audio, and the DAC as an XMOS device. It will not choose any of these, the pulsing Roon icon just keeps pulsing.

I have deleted the program and settings, restarted the PC, re-downloaded the software (roon64) and reinstalled. No change.

My PC/DAC works fine with gaming, youtube, etc. The driver is loaded, and works with other programs. I just can’t get Roon to connect with the DAC, or anything currently. It was working fine before.

I do have a legacy install of MusicBee and more recent Amazon Music app installed, but then they have been installed when Roon worked last month.

Anything else I can try? Short of reloaded Win10 and all.

Hi @Bones13 ---- Thank you for the report and sharing your feedback with us. The insight is appreciated and sorry to hear of the troubles.

Moving forward, can you confirm for me that there are no active firewalls or antivirus applications currently running on the mentioned PC. My sense is that you are not running any other application along side Roon at the same time that could be trying to take control of the DAC but please confirm. Additionally, have you taken any Win10 updates recently?


My office computer is on a network at work with a Barracuda firewall device that has been present for several years. I have not joined this computer on the domain.

The computer is running the Microsoft virus app, but the firewall is off.

Yes, I think I remember Windows updating a short while back.

What to look for and where? Ill check to see if there are new updates pending, I figured a restart would clear any of that junk out.

Hi @Bones13 ---- Thank you for touching base with me and providing the requested feedback, both are very appreciated!

I had asked about the WIn10 update because we have seen automatic updates cause some issues in the past. I would recommend as a test, temporarily of rouse, disabling any active security protocols on the mentioned PC just to test what the performance is like.

Looking forward to hearing your results!

Headed out for the weekend, I’ll have a look Monday, thanks!

1 Like

Back at the office. I disabled all the local protection software on my machine, wow, did Win10 complain about that. Restart, and no different than before.

Pretty sad at this point. Uninstalled Roon twice, with re-download the client.

What else can i try? All the other sound making stuff on my machine works fine (youtube, firefox, games, etc.)

Thanks for touching base with me @Bones13, very appreciated and sorry to hear that the issue has persisted.

When you uninstalled Roon, how did you go about that procedure? Was the DB completed removed before reinstalling?

This should be the steps to follow:

  • Locate your Roon database according to these instructions
  • Rename the entire Roon folder to roon_old
  • Relaunch Roon, sign in, and configure a new install


Thanks @eric , I had erased the database and everything already, without satisfaction.

I have gotten it working now. I think it was an issue with the driver for my DAC. I have a Holo Spring Audio Kitsune Edition DAC, which has worked well. As I was trying to update the XMOS driver for it, I noticed it hanging during the process. After chasing down the 2 places to remove all the driver stuff, and several reboots, I got a clean install of the most recent driver on the Kitsune site. Then a clean install of Roon

Voila, working now, beautifully. I was so close to trying a “repair” of Win10, or a fresh reinstall. This was much simpler. As I have had no trouble with Roon so far, I was certain that it was not Roon itself. I had posted on the boards here in case someone else had the same issue as me, and knew a fix.

I appreciate the support help, Now I can get rid of MusicBee, a poor JRiver clone.

1 Like

Thank you for the follow up @Bones13, very pleased to hear that things are now working as expected!

Happy listening!