Audio device not released at the end of the playback [Solved pending next release]


I noticed that while audio devices are released from exclusive mode upon stop, ctrl+t and a few seconds after pause, they are not released if playback has simply ended, i.e. nothing left in the queue.
To release the device I need to play something and then stop it.


This was a known bug in 128, but was fixed (as far as I know) in 142. Can you confirm that you are seeing this with your Core upgraded to the latest software?

Thanks @brian,

It definitely happened to me in build 142. I will try to reproduce it.


I was able to reproduce it very easily. Played an album, jumped to the last seconds of the last track and let it end.
Then I tried watching a video on YouTube using the same audio device and it wouldn’t play.
I went back to Roon, played something and stopped it immediately, and then I was able to play the YouTube video.

Thanks again

Thanks. Found a case where it wasn’t working. This will be fixed in the next release.

1 Like

Awesome, thanks @brian!

I am also still experiencing this issue. Simply playing back the last track in a playlist and letting it finish doesn’t seem to release the device (movie playback lacks sound). I’m on Windows 10, sporting RoonServer and RoonRemote on the same PC. Using a Totaldac D1-Dual over USB through WASAPI. Let me know if this wouldn’t have been covered by this case you found and I can happily provide more details.