Audio device not switching to Roon - SimAudio Moon 390

Roon Core Machine

Intel NUC 8i7 BEH , 8 GB Ram, 128 GB SSD - Roon Core, 2 TB SSD music files

Networking Gear & Setup Details

Roon Core Hard wired - Audioquest Forest → to Silent Angel Bonn N 8 switch - → Fiber optic switch → EtherREGEN - ‘A’ Side by > Aqvox ethernet cable to Sim Audio MOON 390

Connected Audio Devices

Audio device - Moon 390 Zone 1 by ethernet
Bedroom - Schiit Jotunheim headphone amp with DAC card - fed by Sonoro MicroRendu driving Sennheiser 650 headphones
Raspberry Pi3b+ with original display connected by Ethernet to EtherRegen 'A Side". Raspberry Pi 3b+ is with Ropieee used only as ROON Display - to display whats playing on the Moon 390
Apple TV connected by Network cable to EtherRegen “A” side

Library Size

Library size small 350 Albums, Tidal and Qobuz subscriptions

Description of Issue

The Roon Core is current update
The Sim Audio Moon 390 - Roon - certified device - is running the current firmware
The setup was perfectly functioning till about 4 months ago.
After some recent updates when I press the Roon Play button, I often need to press it 3 to 4 times before the Moon Device switches to Network Player and begins to start playing. The Moon 390 does switch on if its off. But it does not switch to “Network” This was never the problem Prior Ver 1.8
Also I frequently get the error message - “Network Device refused to switch over to Roon”

If I reboot the entire system - power off the Moon 390, wait 5 Min and then switch on, Reboot Core. the system immediately responds - However the same error repeats after a couple of Hrs again.

Further, after Rebooting, frequently, the device is not correctly recognised. I cannot increase the Moon 390 Volume from within roon - the control disappears. This was also not the case earlier. Reboot of the moon 390 is required again to restore the Roon Volume control functionality.

I have been using this setup over 1 year without issues and this has started happening last 3 months or so.

Please help to sort this issue

Hello @Suresh_Kamath,

I’m so sorry to hear about the trouble you’ve ran into with your setup (particularly the Moon 390) and for how long…:sweat:

Could you please navigate to Settings → Audio and open up Device Setup for the Moon 390. Please, make sure to click on Show Advanced. Can you share a screenshot of that screen?

This is a know issue.Eric from Moon said this today.
I wanted to update you guys on the upcoming firmware release for the MiND 2. I have been testing the new firmware for the last few days, and among its many bug fixes, I am confident that this issue is resolved too.
Please check your MiND Controller app occasionally for available updates, and don’t forget to power cycle your device upon completion using the rear rocker switch or by disconnecting the power cable.
Thanks for you patience!
Said there would be a new release in next 2 weeeks

1 Like

Hi @beka
The advanced setting page for the Moon is as attached

Hello @Suresh_Kamath,

Thanks for sharing that screenshot. @Outlaw is absolutely right: a new firmware is on its way and it should fix this issue. Here’s the original post:

Thanks @Outlaw for your help :pray:

Thanks. I will wait for the update

1 Like