Audio Devices disappear everytime

Roon Core Machine

Windows 10 PC, not core

Networking Gear & Setup Details

Connected via ethernet cable

Connected Audio Devices

Soundblaster Z sound card and steinberg UR22.

Number of Tracks in Library

24k

Description of Issue

when I start Roon sometimes it shows all my audio devices connected to the pc, but it then disappears, in the past I never had any problems with it

Check windows firewall is letting Roon and RAAT server through firewall. Windows updates have a habit of causing devices to not be seen as the change some settings.

Hey @Daniel_Morgado

We wanted to check in to see if you were still having trouble accessing your audio devices?

If so, were you able to try disabling the firewall and entering an exception, per CrystalGipsy’s suggestion?

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you are connected to your network via a Private network, not a Public one, see this guide for more information.

Thank you!

1 Like

Hi Ashley,

Unfortunatelly it doesn’t work, when I boot up roon, it shows all the devices with the 2 devices that I use with the red word “enabling” after a few seconds every device disappears.

@Daniel_Morgado thanks for trying that - sorry it didn’t help!

Can you please ensure that the audio drivers are up to date? If they’re not, can you please update them and let us know if that did not help?

Thanks!

they are up to date, and I still have the same issue

A post was split to a new topic: Auralic Aries G1 disappears from Roon

@Daniel_Morgado I’m so sorry for the delay in getting back to you about this, please accept my sincerest apologies! :pray:t3:

We recently released an update to Build 884, since updating, have you still been experiencing issues? If so, we’d recommend a full reboot of all devices in your setup (Core, router, endpoints, remotes, etc.) by powering them down, unplugging them for a few minutes, plugging them back in and powering them back on. Is there any change?

Would you also mind providing us with a screenshot of the Roon Settings → Audio page so that we can get a better look at your devices? I’m hoping that you’re able to provide a screenshot when the “red enabling” feature appears.

Thanks so much!


I’ve did what you asked and it’s still the same. I attached a screenshot, the devices with red test are the ones that I use, and after a few seconds every device disappears from “This PC”. Please help me out a bit quicker since I can’t use it on my main pc.

Agree you running a VPN on the computer? I get the same issues with any DAC connected to my work Macbook Pro when the VPN is up and running.

No, but thanks for the sugestion.

@Daniel_Morgado thanks so much for sending over that screenshot. I’d like to ask, do you have a backup of your Roon data?

Additionally, do you know if there have been any updates to the Windows machine that this issue is occurring on? Does this issue occur on any other device that you use as a Core?

How are these two devices (Sound Blaster and Steinberg UR22mkIII) connected to your Core?

I do, but its actually quite old. the device that I have the problem with is not the core, both devices that I need don’t work, in fact every single device disappears. one is a sound card another is an audio interface connected via usb.

@Daniel_Morgado, in order to assist further, we’ll need a more in-depth description of your setup. It is important that twe understand the environment to make helpful suggestions.

We will need to know what device you are using as a Core, how it’s connected to the internet (you said networking gear was connected via Ethernet - is the Core connected directly to the router?), the model/manufacturer of the router, and how the two devices (Sound Blaster and Steinberg) are connected to the Core.

Additionally, we would recommend reinstalling the application on your Core device, as a next step. Can you please attempt this and if it does not help, could you please provide the information requested in the above paragraph?

Thanks so much!

The core is on another windows PC, It is connected to the router ( tp link archer C7) via ethernet, on another windows pc I have the sound blaster sound card and steinberg audio interface via usb, pc is connected via ethernet, Then I have 2 raspbery pi connected via ethernet as well. If I restart my pc ( the one with steinberg etc,) it works again, but after a while it won’t show up the devices again. The raspberry pi at the moment is not showing up as well.

I will reinstall the core and get back to you again. Thank you for your help.

1 Like

Thanks, Daniel! If after reinstalling the application, you’re still experiencing this issue, we have another suggestion for you to try.

At that point, you can try stopping the Roon Core, going to rooncoredatabasefolder/database/registry/core and deleting all files that begin with endpoint and raat and restarting Roon- if after trying this, is there any change?

We’d also recommend using another PC device as a Core, just as a test. Prior to doing this, we’d recommend making a backup of your Roon data. Do the devices still disappear if another Core is used?

I’m interested to see how these steps go! Certainly let us know if none help. :pray:t3:

Hi Ashley, I tried what you asked, and the problem still persists. I think the problem is related to only the pc I have my devices connected.

@Daniel_Morgado, does the same issue occur if you use a different Core device? (I wasn’t able to determine if you tried this specific step)

If the same issue occurs when using the other PC as a Core, at this point, we’ll want to collect logs to review.

Can you please reproduce the issue, make note of the exact time this happens, and use the directions found here and send over a set of logs to our File Uploader?

Be sure to let me know that you have uploaded the logs (and to let me know of the timestamp) so that we can review them for you! Thank you! :pray:t3: