Audio devices dropping out

Core Machine (Operating system/System info/Roon build number)

Operating System: ROCK Version 1.0 (build 227) stable
Roon Server Software: Version 1.8 (build 764) stable
External 160GB HD

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

SHELL D36E01 (2.4GHz) Router
Ethernet to Intel Nuc Rock

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon Endpoint: Raspberry Pi3 RopieeeXL 3.084, Hifiberry DAC+ HAT. (wi-fi)
Audioquest Dragonfly Red.
Roon remote running on Macbook Air, iPhone, iPad.

Description Of Issue

When listening to either local content or streaming through Roon (Tidal), one of two things will happen.

  1. The Audio device will drop off the list altogether. Then after a few seconds reconnect.
  2. The music will stutter and stop, then move on to the next track.

I assumed it was the Rpi3DAC dropping off the network because of a weak Wi-Fi signal.
To test this I plugged the Dragonfly into a Macbook Air Roon remote (which had been the Core until last week with no issues). The audio drop-outs continued.

The Endpoint dropping off comes with no warning.
But Roon will display an error box when stuttering, ‘An audio file is loading slowly. This may indicate a performance or hardware problem’.

Thank you in advance,

As previously try Ethernet WiFi often fails , that at least will identify the problem

I’ll give it a test. Thanks

I’ve connected the Router to the Rpi Endpoint via Ethernet but still get the audio buffering on both local and streaming.
Also, the endpoint drops off too.

Is your core still analyzing music…

No, it had that done and dusted on the first night.
I set it to 1 Core and it whizzed through it.

Thanks though

Hi Mat.

Have you had a satisfactory answer as I’m suffering similar breaks in the digital stream only solved by rebooting my streamer.

I’m also a victim of this issue.
Either on wifi or 1Gbps Ethernet. Core is doing fine, performance wise.

Hi John, no nothing yet.
Official support haven’t been in touch yet, but to be fair I can see that they’re getting run ragged.
I’ve been playing a bit of music today and so far it’s been behaving.
It could have been just a settling in period for the Core and Streamer? Who knows?
I’m going to keep testing over the next couple of day and I’ve picked up a Pi4 to see if that’s any better.

Since spending (a lot) more time on this forum and reading through everyones issues, I’m learning that the potential reasons for my particular issue happening are endless.
I’m still leaning towards a possible network issue at my end.
So hopefully someone will get in touch and take it from there.

Me too. The Core and streamer are quite happy.
I’ve noticed that some folk are reporting there devices go missing altogether but mine always pop back up 5 seconds later.
The ‘Tidal loading slowly’ box followed by moving onto the next track is infuriating though.
Here’s hoping someone will be along to help. :crossed_fingers:

I had that issue with missing endpoints too.
Rebooting the core and endpoints (I have Pi’s with Hifiberry DAC’s) does not make any difference.
It’s a bug introduced recently no doubt.

Ah ok that’s interesting.
Well I won’t spend too much time worrying about that side of things then.
I appreciate that everyone’s issues are slightly different, but it’s great that I’m able to hear what has or hasn’t worked for other people.
Thanks for that.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.