Audio devices missing following Arc set-up

Core Machine

NUC8I5BEH3 I5-8259U, Samsung 250GB 970 M2, 8GB DDR4, ROCK installed

Network Details

NUC connected by Ethernet to router Virgin Hub 3 (previously connected via ethernet splitter that was then connected to router). Router connected by Ethernet to Linksys Velop Mesh master node for WiFi across the house (four nodes in total).

Audio Devices

Cambridge 851N (Roon Ready) connected to Linksys WiFi
iMac M1
iPad (Linksys WiFi)
iPhone (Linksys WiFi)
Sky Q (AirPlay)
Sony TV (Chromecast)
Sonos One (x2 WiFi)
KEF LS50 Wireless II (Linksys WiFi)

Library Size

44710 tracks (connected to NUC by USB to a 4TB external hard drive)

Description of Issue
Up until yesterday all was fine, but I couldn’t connect to Roon Arc remotely outside my home network. After testing via the Roon app, it suggested that this may be due to multiple NATs. I looked at the NUC’s connection and it was connected to an ethernet splitter (and then to the router) rather than direct. I turned the NUC off, switched the ethernet direct to the router, and turned back on. Roon ARC now successfully connects to my Roon Core (hurrah!) but now no audio devices show up at all - none of my Roon Ready systems, airplay, Chromecast. Ideally I don’t want an either/or situation (choosing between Arc access or home devices), so any help would be great!

Actually, I think I have worked out the issue, which may be helpful for other Mesh owners, but I’m not sure if there is a solution. Roon Arc is now working as the NUC is directly connected to my central router. But all my audio devices are on the Linksys WiFi, which the NUC will only be able to connect to when its ethernet cable is connected to that (rather than the router). So I basically have the choice between one or the other - I can’t see a way to be able to have the NUC connected to the Mesh Wifi in my house, and be able to connect to the router to enable use of Roon Arc. Thoughts welcome!

Hi @David_Flynn,

This is actually a common issue that even Roon employees have encountered in our testing of Roon ARC. In some cases, a mesh setup must be configured for Roon ARC as well as any ISP modem.

However, your setup now (connected via ethernet) is the best way to use Roon. Roon cores should be hardwired wherever possible for the best possible stability and listening experience.

I’m glad you’re up and running though and if you need any further assistance, please let me know.

Kindest regards,

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.