Audio Devices Not Found [Solved - Faulty PS Bridge]

My setup.

PS Audio PWD 2 + Bridge 2. Latest firmware.
Roon installed on Gigabyte Brix I7-7500 and 16GB.
WINDOWS 10.
Samsung Evo 850 SSD 1 TB dedicated to music files built in pc.(brix)
Cat 700 cable audioquest to router (Fritzbox 7490 latest firmware).
PS Audio PWD 2 Cat 700 cable audioquest to router (Fritzbox).

When i play music everything is o.k., but afther 2 days not llisting to music and or use another source the message is.
No audio Devices Found.
Manage audio Devices.

Nothing helps, only to shut down the PS Audio compleet and start up again.
I like to have a constant connection.
What do you suggest i can do?

Hi @Leon_Blijenberg ----- Thank you for the report and sharing your feedback with us. Both are very appreciated!

When you see these messages in Roon: “No audio Devices Found” / “Manage audio Devices”, my assumption is that the “audio” tab shows no devices, but please confirm. Furthermore, as a test (with Roon not running), could you please access the same directory in which your database can be found and delete your RAATServer folder. Please let me know if things stay stable.

-Eric

Hi Eric and @Leon_Blijenberg

Looks like Leon and I are having similar issues except that I have never been able to get Roon to detect my PS Audio Directstream.

I just signed up to Roon and Tidal yesterday to match my PS Audio Directstream DAC with Bridge II (Torreys Firmware), but cannot get Roon to detect the Direcstream.

My Network router device (Fritzbox 7490) identifies the Directstream on the network, and the Directstream in Bridge mode indicates a green network icon, and shows the router IP address correctly. Roon identifies the Sonos player and Apple TV which are connected to the same Gigabit switch that the Directstream is also connected to, but cannot detect the Directstream.

Roon (v1.3) has no trouble accessing my (new) Tidal account, and can also access my music files on my Synology NAS. Roon is running on an iMac 3.2GHz Intel Core i5 with 16GB RAM and fusion drive (SSD/HD) with OS 10.11.6. The internet comes in through the Fritzbox 7490 router in my garage, with Cat 6 Ethernet connections directly to the iMac in my study, another Cat 6 Ethernet to an Apple Airport Extreme (static IP). This has one Cat 6 connection to my Apple TV and another Cat 6 connection to a Belkin 5 port Gigabit Switch. This Switch is then connected to my Sonos, Direcstream and Synology NAS.

I can play Tidal on my Sonos, which connects to the Direcstream by Toslink, but this is not as good as I have heard the Bridge II connection to be.

My Fritzbox 7490 identifies the everything on the network, so why can’t Roon identify the Directstream?

I will try to attach the layout of my network.

Many thanks!!

Phil

Hi again @Eric and @Leon_Blijenberg

Here is a screen grab of my Roon settings - Sonos and Apple TV are visible, but not the Direcstream.

Cheers,

Phil

Hi Philip,

Do you have the latest bridge firmware installed ( 2.15).
Also switch the dsd off and on, on the back will help.

Succes hope you will enjoy roon soon.

Hi @Leon_Blijenberg,

Thank you for your reply. I have just installed the latest bridge 2.15 and have turned the DAC off and on, but still no visibility to Roon!

The Directstream definitely sees the network, and the network on my iMac can see the Directstream but Roon cannot.

The Directstream now indicates N/A in the ‘Firmware Update’ window, and Bridge 0.0.0. Which is what PS Audio states it should show after the Torreys update. What I’m not sure about is whether I should have updated the Bridge firmware before the Torreys firmware?

Should I go back to a previous version of the Directstream firmware, re-do the Bridge firmware, then update to Torreys?

Thanks again,

Phil

Hi Philip.

Are you 100% sure to have a bridge 2 not the first bridge type (won’t work with Roon).

This info found on PS audio forum.

  1. Turned off dynamic IP for the bridge and set it up for static IP. There is an article under “Resources\How To” on this site that can help with doing this.
  2. Once I restarted the DAC, I could see the upgrade option for the bridge… something that was N/A previously.
  3. I upgraded the bridge. Interestingly, the bridge firmware version was still 0.0.0.
  4. Now, Roon can see the DAC under Roon Ready devices as stated by ksalno.

Hi @Leon_Blijenberg

Thank you once again. I am 100% sure I have the Bridge 2. I still have the box, receipt, and the Directstream calls it ‘BridgeII’. I already tried turning off dynamic IP through the PS Audio ‘how to’ site, but despite trying it several times it always defaults back to dynamic, and the upgrade option for the bridge never changes from N/A. I spoke to our AU Distributor. He reckons there’s a roundabout way of updating the bridge firmware, but his technician is away at the moment.

In short, I’m sure you are right - it is a Bridge Firmware update issue. PS Audio give a Bridge Firmware update file in their downloads section, but it is not clear how to do the upgrade - should I upload the Bridge Firmware update code alone on the SD card, or together with the Torreys Firmware code? I have done both and neither seems to work for the bridge. If you have any suggestions on this step, I would be most grateful.

Thanks,

Phil

Try turning the firewalls off on your network as a test and see if that makes a difference.

Hi Philip,

The original sd card from ps audio with driver for the bridge 2 was not working.
I download and copy the 2.15 driver to the sd card and after the upload roon regonised mij bridge 2.

Please visit ps audio forum for other tips.

Leon.

Hi @Leon_Blijenberg and @philr

Thank you for your replies. I found out that the Bridge cannot be upgraded via the SD card, only via the USB slot in the Bridge, or via the web ‘Firmware Update’ GUI on the Directstream, or potentially via accessing the Bridge by entering the IP address on the home browser.

I tried the Bridge Rescue driver from PS Audio (on a 2GB FAT16 formatted USB), followed the instructions to update the Bridge via the USB, but that didn’t work. I then loaded the upgrade-0.2.15.ub file to the same USB (removing the rescue driver) and repeated the process. That also didn’t work. I turned off the Firewall to that IP address and that didn’t work either.

The Bridge recognises the router IP address, and the router recognises the Directstream. I cannot access the Directstream bridge by entering the IP address in my browser. I suspect that somehow the Bridge Firmware is failing to update despite all these measures. I am awaiting a response from PS Audio support. I guess it may have to be returned and sorted.

Thanks again for all your suggestions.

Kind regards,

Phil

Hi Philip,

I hope you will enjoy Roon soon i like it very much.=20
Do not know the solution for you right now.

The ps audio pw dac is a , do not know how the dsd sounds.
I got a ssd 2 tb dedicated with music in aiff and stream this to my dac with=
a cat 700 forrest cable from audiquest direct from my router ( from all the=
other network) to the ps audio.

When i’m late at home i like to relax with music and even on low sound level=
the bass en sq are awsome.

Hi Leon

Just to update you… I ended up getting great support from PS Audio, but my Bridge ended up getting sent back. A new one will be shipped to me.

I have already upgraded to Huron Firmware which is absolutely amazing!!

Thanks

Phil

Hi @Leon_Blijenberg and @philr

My PS Bridge ended up being sent back to the distributor, where it was tested and found to be faulty. That explains all my difficulties.

PS Audio will replace it, and I should then be able to enjoy the full capacity of the Directstream!

Regards,

Phil

1 Like