Audio dropouts when playing "Money" from Pink Floyd's Dark Side of the Moon (2003 remaster) on Roon with MacBook Air M2. Roon utilizes high CPU and memory usage (ref#FQQNOJ)

Full form submission

What’s happening?

I'm having trouble playing music

What best describes your playback issue?

I'm hearing dropouts

When playing ‘Money’ from Dark Side of the Moon (Pink Floyd - 2003 remaster) I often hear dropouts. This doesn’t happen when using Qobuz directly, only with Roon. After playing that track, no more dropouts. Very strange!

I’m using a MacBook Air M2 with 16 GB. Roon is taking about 60% of CPU time! And 1 GB memory.

Hello @Serge_Nelissen ,

Thanks for reaching out here. Are you still seeing this issue after updating to our latest Roon release from today? If you are, can you please let us now the exact local time + date when you hear the dropout? We can then enable diagnostics mode for your Server to see if we can find more clues regarding the dropouts. Also, please confirm if the dropouts are limited to one zone or if you are able to reproduce on multiple zones (for example on System Output too). Thanks!

I will do some more testing but… I’m running out of time on my trial period (I have another issue with my Sony Bravia TV). Can it be extended please?

Thanks,

Serge

So… playing through Linn Akurate DSM/1 (Roon ready streamer):

  • playback 1, drop outs at: 2:50, 2:55, 3:03, 3:06, 3:36
  • playback 2, drop outs at: 0:51
  • playback 3, drop outs at: 0:19, 0:21, 0:27, 0:52, 1:34, 1:37, 1:42, 1:48, 2:03, 2:12, 2:18, 2:34, 4:03, 4:10, 4:32, 4:39

No dropouts playing another track.

Playback of the same track, but on my MacBook speakers: no dropouts.

Very, very strange!

I watched my CPU load and didn’t notice significant changes during dropouts. I’m just amazed Roon takes about 50% on an M2 MacBook. Maybe I should consider a Nucleus ?

Going to update now…

Serge

Did the update… same problem!

Hey @Serge_Nelissen,

You got it! Please, check your account page for the new end date for your trial :smiling_face:

Thanks a lot!

1 Like

Now playing a whole list… more tracks suffer from drop outs :frowning:

Hint!

On my Linn streamer, I have an indication if the stream is feeding ( > symbol), waiting (hourglass) or stopped (square). During the drop outs, the indicator shows an hourglass!

So, it has to do with the stream between the Roon core and the Linn streamer, not with the internet connection between the core and Qobuz. That’s also why I get no drop outs when using the Mac’s speakers.

The percentage value in Activity Monitor shows load per core, so it’s not as bad as it looks.

As for the dropouts, how are your MacBook and Linn Streamer connected to your network? If either or both of them are on wifi it’s likely that that’s the problem. If you can, try hard wiring them both and see if it makes a difference.

If hard wiring isn’t an option, take a look at your router settings to see if you can prioritise the traffic to your MacBook and the Linn.

Can you explain please?

I will, but I need a docking station… I ordered one now.

Thanks,

Serge

The CPU in the MacBook Air has 8 cores, i.e. the equivalent of 8 CPUs which run concurrently. When you check Roon’s CPU usage and Activity Monitor reports this as 60%, this isn’t 60% of the CPU capacity of your MacBook, it’s 60% of one of the 8 cores. This equates to 7.5% of the total capacity.

Really???

Stupid performance monitor i.m.o.

Thanks

Serge

Ok, I connected a USB port from my Mac via a docking station to a wired Ethernet connection. It doesn’t help since Roon only ’talks’ to my DSM via airplay. But, I was able to connect a TOSLINK cable from my docking station to my DSM.

NO DROP OUTS ANYMORE!

I wasn’t aware my wifi was so unstable :frowning:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.