"Audio File Loading Slowly..." message for some endpoints while others work as expected

(Barry) #1

Core Machine (Operating system/System info/Roon build number)

MacOS 10.14.5/4.2GHz i7/40GB/1.6 (build 416), connected via ethernet to…

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Orbi RBS50 (with Disable IGMP Proxying unchecked), 3*Orbi RBS40, Orbi RBW30.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Auralic mini, Chromecast Audio, Chromecast Ultra 4k, Devialet Phantom, HomePod, iPhone XS, 11" iPad Pro: all WiFi.

Description Of Issue

Some Roon endpoints are strong, others are weak.

I have a bunch of different end-points. When everything is rebooted and clean, all is well. After a time of switching end-points, and sometimes grouping, the end-points fall into two buckets:

Strong end-points, that never refuse a Transfer Zone connection:

  • Devialet Phantom via AirPlay; Chromecast Audio; Chromecast Ultra 4k; HomePod

Weak end-points, where sometimes the time counter moves and sometimes it doesn’t, but music doesn’t play and I get continual “An audio file is loading slowly…” and track skipping:

  • Auralic Mini*2, via either AirPlay or Roon, via USB to either Peachtree nova300 or Rotel 1592; iPhone XS; 11" iPad Pro.

It is super-annoying that the cheap-as-chips Chromecast end-points are bullet-proof, whilst the expensive Auralic and Apple end-points are not.

Am I alone in this?

Adding music to library: stuck indefinitely
(Noris) #3

Hi @Barry_Skingle,

Can you let me know if the endpoints affected by this behavior are all connected to one specific Orbi access point? If you try connecting your iPhone/iPad to the primary access point, does the same behavior still occur? Does this issue occur with both local and streaming (TIDAL/Qobuz) content or just one type and not the other? Are you using the newest firmware on your Auralic?

(Barry) #4

Hi Noris

Naturally, having raised this issue, all my endpoints have been performing flawlessly, until now.

The end-points are connected to different access points, right now:

  • HomePod -> Orbi day-room
  • iPad -> Orbi study
  • Dialogue -> Orbi lounge
  • Aeries Day-room -> Orbi day-room
  • Aeries Conservatory -> Orbi day-room

I disabled wi-fi on the iPad, stood next to the Orbi router and reconnected. Music did not play for about 30 secs, then started playing.

In conducting these tests I have noticed that Roon playback to the Aeries endpoints is more fragile than Airplay playback, in in both cases skipping to the next track sometimes produces music (the playtime tends to advance with Airplay and not advance with Roon).

On the Aeries devices I am running 6.1.1, which I believe is the only version supporting Roon?

It seems to make no difference whether the music is hosted on the iMac or streaming.

Some screenshots:

(Noris) #5

Hi @Barry_Skingle,

Thank you for sharing those screenshots. I have gone ahead and activated diagnostics mode for your account and what this action does is automatically upload a set of logs to our servers for analysis.

I can confirm that the report just came in and after looking over it now, I believe this to be a networking issue and we should troubleshoot further in this direction. Can I please ask you to perform the following 2 tests?

Test 1:

  • Disconnect your iPhone XS from the Roon Core and disable the Wifi for the time being to ensure that it does not interact with anything on your WiFi network

  • Reboot your Core

  • Verify if there is any change in behavior and if the loading speeds for the other devices are different with this device disconnected

Test 2:

  • Have all of your access points unplugged from the power source and leave just the primary access point or router active

  • Connect one of the more problematic endpoints + the Core to the primary router/access point and do not have any other endpoints connected

  • Reboot your Core

  • Verify if the long loading behavior still occurs

(Barry) #6

Hi Noris, thanks very much for this.

This is after a quick set of tests.

Disconnecting the iPhone did seem to reduce fragility. But a few frequent transfers across the Aeries and iPad got me back to lots of drop outs. Powering down the access points made an immediate, positive difference (the iMac core is ethernetted to the router, btw). Rapid transfers between fragile end-points still results in drop-outs, but usually skips to the following track which plays okay.

Did that provide any useful diagnostics?

(Noris) #7

Hi @Barry_Skingle,

Thank you for running those tests. I am taking through the logs now, and I do see quite a few abnormal traces listed in them, so I am going to go ahead and reach out to our QA team who will be able to provide further analysis for this issue.

Do note, it may take a bit of time for my request to reach their queue, but I think it’s best that we loop them in and request their expertise for this case. Thank you in advance for your patience here, and I will reach out as soon as I have any further info to share.

(Barry) #8

Thank you, Noris. Just to note, the chromecast and Devialet end-points remain rock solid.

1 Like
(Noris) #9

Hi @Barry_Skingle,

Thank you for your patience here while QA has been looking into this issue further. Analysis is still on-going but they have requested some additional info as to pinpoint this issue further. Can you please let me know the following?

  • What is the size of your Roon library? Can you please navigate to Roon -> Overview tab and share a screenshot of number of tracks/albums/artists present?

  • If you try connecting two endpoints that exhibit this behavior directly via Ethernet to your router or primary access point, does the same behavior still occur? The test here would be: Have Aires + Core connected via Ethernet, try transferring the zones just between your Aires and a local Core output (System Output or one of the USB zones), see if the same behavior occurs.

Can you please let me know those two pieces of info when possible?

(Barry) #10

Hi Noris, thanks for getting back to me. Here’s the screenshot - it will take a little longer to configure an Aires over ethernet.

1 Like
(Barry) #11

Hi Noris. So, now Conservatory Roon (Aeries Mini), the iMac Core (Study headphones & Study speakers) and the Orbi router are all connected to the same gigabit ethernet switch. The Aeries Mini is outputting via analogue (!) rather than USB.

After a few dozen end-point switches wirelessly from my iPhone XS, without rebooting any network device or anything except the Aeries mini, not only are the Conservatory Roon and Core endpoints solid, but so are all the endpoints I tried (including the iPhone XS).

Could the problem be interference between the two Aeries Minis over WiFi?

I can’t really get ethernet to either rooms where the Aeries Minis live, except perhaps ethernet over mains.

Thanks for your on-going help.

(Barry) #12

Hi Noris

I’ve now swapped things around, so I have Roon Dayroom (Aries mini) connected via ethernet over mains and Roon Conservatory (Aries mini) back in the conservatory connected over WiFi.

Firstly, every endpoint now seems solid.

Secondly, I can now successfully play over AirPlay to grouped RoonConservatory+RoonDayroom+Phantoms+Homepod, which hasn’t worked for months.

Could this problem stem back to September when I bought the second Aries mini, and they have been intermittently colliding over WiFi ever since?

BTW, I believe that all of this is independent of the iPad disconnecting problem reported Remotes are losing connection to Core machine and iOS remote connection trouble, which is still happening.

Thank you as always.

(Barry) #13

So, I spoke too soon.

On going back, Roon Conservatory claimed to be playing (with play time progressing), but no music emerged. Roon Dayroom refused to play, then rebooting Aries Mini did play, then went back to slow loading.

It’s like there is some buffer which gets reset when I make a configuration change, and when it’s exhausted, chaos ensues. :pensive:

(Noris) #14

Hi @Barry_Skingle,

Thank you for the update here but to properly troubleshoot this issue, we should try to only change one variable at a time to see where the issue lies. I am a bit confused as per your latest posts, let me try to clarify a bit:

  • Roon Conservatory was connected via WiFi and Roon Dayroom was connected via Powerline
  • Both of these endpoints had issues after a while
  • Question #1 - Were they still grouped or were they playing as individual zones?
  • Question #2 - When the above issue occurred, were the iMac Core local zones working as expected?

As I mentioned, it would be best to take troubleshooting one step at a time and see where exactly it stops working. By this I mean:

  1. Do not have any of your zones grouped

  2. Have one of the Aires connected directly to the Router as well as your Core. Leave the other Aires out of the equation for the time being

  3. Have all of your active endpoints connected to the same Router

  4. Verify if any issues occur over a period of a day while playing to various endpoints

  5. Repeat the same test with the other Aires, leaving only one connected at a time

  6. If playback stops on just one of the Aires but the other one works as expected, we know which direction to take a closer look in

If you can perform this test, it should give us a good data point. I should also mention that the symptoms you are describing may also be an indication of an unstable network setup or an issue with the router itself. As such, I would reach out to Orbi and ask if they can run a diagnostics check on all of your Orbi gear just in case there are any hardware issues in this regard.

(Barry) #15

Hi Noris, thank you for your update.

I take your point about changing one variable at a time. It is significant I think that following reboot or reconfiguration all end-points can be completely solid for a while: the problem takes time to rematerialise.

To clarify on the points above:

  • I ungrouped after the 6:02pm post: there were no grouped end points in the 9:33pm post
  • Yes, Roon Conservatory was connected over WiFi and Roon Dayroom over power line
  • Yes, both end-points had issues after a while
  • They were playing as individual zones
  • I did not test the iMac local zones (I will check next time): I have never seen a connection timeout on the iMac local zones (nor on the Phantoms via AirPlay nor on any of the three Chromecast endpoints)

I have powered-off Roon Conservatory for the time being (reverting to Chromecast in that room).

iMac Core, Orbi Router and Roon Dayroom (via power line) are connected to the same switch.

I’ll let you know how it goes.

Thanks again.

1 Like
(Barry) #16

Hi Noris, with the configuration above, music has been playing perfectly between Dayroom Roon (via power line) and Conservatory Chromecast. And I’ve just walked around and successfully transferred to:

  • Lounge Chromecast
  • Lounge Phantoms
  • Dining Room HomePod
  • Dayroom AppleTV
  • Study Headphones
  • Barry’s iPad
  • Barry’s iPhone XS ( I did get a timeout as a news alert came in, but that’s understandable)

So, it seems that all is good with just one Aries Mini online.



(Barry) #17

(Barry) #18

Hi Noris, yesterday music was playing fine from Conservatory Chromecast when I had a Core crash: is there a way to upload the full dump?

Process: Roon [34493]
Path: /Applications/Roon.app/Roon
Identifier: com.roon.Roon
Version: 1.0
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Roon [34493]
User ID: 502

Date/Time: 2019-07-21 19:46:29.759 +0100
OS Version: Mac OS X 10.14.5 (18F132)
Report Version: 12
Anonymous UUID: 0AFB21C8-7ED8-3C29-68CE-782E761C3077

Time Awake Since Boot: 780000 seconds

System Integrity Protection: enabled

Crashed Thread: 5 Broker:Transport

Exception Codes: KERN_INVALID_ADDRESS at 0x000000112470c9c8

I restarted the Roon app on iMac.

Then I had several timeouts on Dayroom Roon (perhaps that’s not surprising?):

I then switched zones to Barry’s iPad (paired with a Bluetooth speaker), and after a few minutes walked outside. At this point the iPad probably changed access point, I imagine from Orbi Dayroom to Orbi Garage. The music stopped playing, and in the Roon app on the iPad the end-point Barry’s iPad had disappeared:

Using the iPad, I switched zones to Conservatory Chromecast, which (as always) performed flawlessly.

Thanks for your continuing help with this.


(Noris) #19

Hi @Barry_Skingle,

Thank you for confirming this aspect. Since the Dayroom Aires is working as expected, we should take a closer look at the Conservatory Aires, possibly reinstalling the firmware on the device would be a good next step.

Yes, if you wish you can upload a log set to Dropbox or Google Drive and provide a link, I can take a look that way. Also, diagnostics mode is active but I do not see a new report yet, next time you boot up your Core I will be on the lookout for any new reports.

After sending the crash log over, I think it’s best that we try to verify the behavior of Roon with a fresh database as a temporary test. You can set your old database aside by using these instructions and I would be curious to know if they help mitigate the amount of issues you are seeing:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
Adding music to library: stuck indefinitely
(Barry) #20

Hi Noris, firstly, here’s the core crash: https://www.dropbox.com/s/th3yiodjhkurqs1/Roon%20quit%2021%3A7%3A19.rtf?dl=0

(Noris) #21

Hi @Barry_Skingle,

Thank you for sending the log over, I can confirm that I have received it.

Please try the second part of my instructions when you have a chance, I would like to see if the same issue occurs with a fresh database. Note, please do not restore from a backup once you set the old database aside while we run this test.

Adding music to library: stuck indefinitely