Audio glitches with Bluesound Node 2i (seems after 1.8 upgrade)

I encounter very annoying, numerous audio glitches after upgrading to 1.8 it seems.

for me to reproduce:

  • playing 'We May Never Pass This Way (Again) from Seals & Crofts, either via Qobuz or Tidal to Bluesound Node 2i starts with cracking/glitches, and later in the song again
  • both using headphones directly into the Node, or via NAD amp (both optical / RCA)
  • checked all cables then, no problems
  • no problems using BluOS app, or Tidal Connect using the Node!
  • no problems when playing Roon to iMac via Audient ID14!!!

So there seems to be a problem with Roon in combination with the Node?

I suspect after upgrading to 1.8, but I’m not 100% sure.
Roon running on upgraded Synology NAS, never got any problems before.

Any tips?

Cheers, Rein

Hello Rein,

You are not alone. I have exactly the same issue.
Sounds as if there is some transport problem, sounds like static discharge at some point faint, sometimes more prominent.
I have a similar set-up with Synology NAS to Node 2i. That one is with cable. A Pulse Flex is via WIFI, same issue.
Checked my cable connection, played the same music via the Zappitti streamer and have no issues. It only happens when I use Roon. Roon runs on SSD on NAS. I am 99% confident it has to do with Roon as a result of the different tests.

1 Like

Hi Michael,

Thankx for your reaction. The strange thing is, for instance in mentioned song it happens at the same spots!

for me, it seems somehow the combination of Roon with the Node 2i, since it does not happen when I use Roon via my iMac in combination with an Audient ID14 soundcard.

Yes, indeed. Listening via the Bluesound control, same source (NAS) no problem. Switching back to Roon the flutter is immediately noticeable, currently Pink Floyd Shine on you crazy diamond and at the intro several times in the first 2 minutes.
Definitely Roon, since only the transport method has changed.
Think this calls for a ticket to Roon tech guys.

Hi Michael,

I’m still in doubt whether this is solely a Roon thing, since I do not have any of these issues when I stream from Roon on my NAS to the iMac / Audient.

But it still sucks :frowning:

Cheers, Rein

Hi all,

I seem to be having the same issue, and it just happened overnight, no apparent updates, no changes to my system. Did any of you find a solution in the mean time? My setup is a bit different however, I run Roon on my PC instead of my Synology NAS.

Kind regards,

Tim Verhoogt

Strange! Nope, unfortunately still not been solved.
In doubt now whether I’ll continue the Roon subscription …

Using the BLuOS app more often…

It has not been solved on my end either. I have used different routes to my speakers. I have multi room set up, or single room, no difference. When playing the same music via BluOs the issue is gone. Source the same. Using Zapitti instead of Bluesound with same source, no issue. Bits & Bites going through the same cables and switches. Using Airplay mode it is not as distinctive but still there. Roon tried to help, diagnostics and all, but did not find anything. I am baffled. The only thing not done is roll back the update to 1.7 on the software, but not sure that will solve it, as 1.8 is the way forward. I am following the ostrich strategy on this one and hope it will go away. Need Roon for the mix in airplay and BluOs speakers.

For now: solved after applying latest update (build 795)!

fingers crossed that it will stay this way :grinning_face_with_smiling_eyes:

My Bluesound Node 2i, connected with ethernet is working without any hickups.
The Roon Core is on an Mac Mini (late 2012) with Ubuntu 20.04.2 LTS as OS, direct connected with ethernet.
Core and Bluesound Node 2i have the latest versions resp. 1.8 (build 795) and 3.14.5
All previous Roon 1.8 versions worked without problems on the Node 2i.
Streaming service is Qobuz together with my local library on SSD.
Before switching to Qobuz i used Tidal without any problems.
All connections are Gigabit, network gear is Cisco and MikroTik.

@PeterD I’m not sure if you are saying from your post whether you are now having the issue following build 795 or not.

However, I definitely am. Everything was working fine until I went to 795 and I get a scratch sound every 20-30 seconds or so.
Intel NUC gigabit connection to my bluesound and very little CPU showing.


Thanks, I thought worth checking given the thread had been brought back to life.

Kind of hoping someone else has seen this regression since 795. Next step for me to is go around rebooting my router and switches, perhaps just try over Wifi as well.

I do not have a Node 2i but do have many other Bluesound and NAD BluOS enabled pieces. Whenever I have heard clicking or static occur - the problem seems to come down to the presence of MQA and/or bit depth/sampling frequency changes. The problems have come and gone for me on occasion with software updates - but the solution always seems to be the same.

  1. Turn off MQA processing in Roon and/or device settings.
  2. Add a significant delay (3000-5000 ms) in the device settings for a change of bit depth/sampling frequency.

Please understand I am not trying to knock MQA in saying this - but anyone that owns NAD/Bluesound gear and spends significant time on this forum should have noticed that MQA and bit depth/sampling frequency come up over and over again.

Not sure what the actual issue is as a layperson, or who is to blame for this issue - and I really don’t care any more. But I have found that turning off MQA and having a 5000 ms delay in place on all these devices keeps these issues at bay.

1 Like

Thanks for your comment, were do I find these settings? Cannot find it on my iPad in the settings. :man_shrugging:t2:

In the device setup panel - try these settings.

MQA Capabilities - No MQA Support
Resync Delay - some value that brings relief

Please keep in mind that I have no deep knowledge as to why these settings may or may not work for all people. All I know is there has been a clear correlation between complaints of static/crackling/popping and MQA/bit depth/sample rate changes on this forum and others. People suggested mucking around with these settings - and I did and it worked. I have kept these settings this way for some time and do not have these issues any more with my NAD 658, 758v3, and M10.

I tinkered with the Roon DSP and MQA settings as well, but unfortunately the issue persists. When I do A/B comparison with Tidal MQA to Qobuz HR (or regular streams, ór music from my server), the glitches are there for both streams, albeit at different parts of the music.
The only change I made before this issue was installing a nest thermostat. As this could cause extra wifi noise, I took some time to rewire all my electrical and data cables. Now my computer is (still) running as a Roon Core but is directly wired into my Archer AX50 router, which in turn is wired to my bluesound node 2i (all CAT5E). The bluesound node is connected to my amplifier with coax ánd analog. The amplifier and node are plugged into an audioquest powerconditioner. I also reinstalled Roon and reset my router. Before I found this topic I was considering an Intel NUC as dedicated roon server, but I changed my mind.
I feel like I tried my best to rule out any other causes to the glitch issue, but to no prevail. Tidal connect and bluOS streaming give no issues and sound flawless. I was using Roon with no issues since November 2020.

1 Like

Thanks for the help, sadly no effect for me. For now it is either Bluos direct or airplay mode, which has the issue less prominent. Reading all different issues, I just hope Roon can find the cause and fix it. Do not want to lose Roon.

I just got an update message for my bluesound node, and I crossed my fingers, installed the update, and the glitches are gone!! Still not sure what the problem was though, but I hope this update (3.14.20) will fix all your glitch problems too.

Kind regards,