Audio glitches with Bluesound Node 2i (specifically following 795 upgrade)

Core Machine

Intel NU8i5. Ubuntu 20.04.2 (fully updated). 24GB RAM, 256GB SSD

Network Details

Netgear Switch. Everything on Gigabit Ethernet.

Audio Devices

Bluesound Node 2i, connected as a ‘Roon Ready’ device rather than via Airplay.

Library Size
Around 10,000 tracks.

Description of Issue

Since I updated to 795 I get audio glitches every 20-30 seconds, almost like a scratching sound - not drop outs or pauses.
This happens regardless of whether I use Tidal, Qobuz or local files. Also tried different resolutions.
I have rebooted everything and this did not fix it.

Everything works fine with BluOS, both with local and streamed content.

Never had the problem. I’m a lifetime subscriber and I’ve been running this setup for over 12 months and literally started failing after the upgrade to 795 so it must be that. Can I revert to the previous revision please as I cannot use Roon anymore with this fault in.

Any comments/thoughts/requests such as logs?

Hello @Rob_Kirkbride,

I couldn’t be more sorry that we’ve missed your post for this long - please, accept my apology :pleading_face: . As you might have seen if you browsed at all on our community, we are a bit late on getting back to all the posts we’ve received. Things are looking up and I’m confident things will be much faster from now on :nerd_face:

Thank you for such a thorough post explaining the behavior you’re experiencing. I wanted to ask if you’ve updated your Bluesound Node 2i to the latest firmware. Could you please turn it off, unplug it for a couple of minutes, plug it back in and start it up? Does that help?

Thanks in advance :pray:

Thanks for coming back. It appeared to get fixed with the recent BluOS upgrade which came out after the Roon 795 upgrade.

Does seem strange, not sure whether the Roon upgrade triggered a bug in BluOS which they then fixed or something else. The only other thing is whether the upgrade did some kind of hard reset. I must admit I never tried leaving it off for 2 minutes like you suggested.

So it’s back to working now.


1 Like