Audio Issues when using all local files on Roon

Core Machine (Operating system/System info/Roon build number)

Windows 10/Surface Laptop 256gb 8gb RAM/ Roon Build 1.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Local issue - not network related.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Surface Laptop output (not connected to any audio equipment)

Description Of Issue

I’m getting awful audio quality when using Roon to play my tracks. There’s some strange kind of bass resonance coming in the low-end. This does not happen when I play the same tracks in Foobar.

The signal path is very simple and it says that it’s not doing any processing with my audio. These are all files played from my C drive. It happens regardless of what the audio output is - my computer/headphones/speakers etc.

These are local files - not related to Tidal/Qobuz etc.

I’ve recorded two clips - one when playing a track in Roon and the other when playing the same track in Foobar. This should describe what the issue is - listen to the sound when the bass kicks in.


Hi @Jake_Billington,

Can you share a screenshot of Device Setup?

Do you have exclusive mode enabled?

Here is my Device Setup - I think it’s all defaults.

I can’t seem to find anything about an ‘Exclusive Mode’ in the settings.

I think your Surface probably has two Audio devices available to Roon. There’s the System Output, which uses the Windows audio mixer, so other audio streams (e.g. from notifications, or other applications) are also mixed in, together with any audio processing that you may have enabled in Windows.

Then there’s probably also an “Intel SST Audio Device (WDM)”, which gives Roon direct access to the audio hardware. If that’s present, you could try that output and see if the sound is different/better…

Hi Geoff. Thanks for the recommendation but no luck. The strange thing about it is that the same tracks played from Foobar/Groove/iTunes do not have the interference - it must be something which Roon is doing with the audio.

Hi @Jake_Billington,

Can you share a screenshot of Settings > Audio so we can see all of the devices available to you here?

See below:

This is my setup when i’m hooked up to my Surface Dock. When I play a track through ‘Intel Display Audio’, ‘System Output’ or ‘Realtek HD Audio’, I get the issue. Funnily enough - if i’m hooked up to my Surface Dock and I play it through that I do not get the issue. This doesn’t fix it for me though as when I’m not hooked up to the dock I always get the interference.

Hi @Jake_Billington,

Do you have any other audio programs running in the Windows taskbar?

No I don’t.

And all the sound “enhancements” that the Surface usually comes with are off?

Yes - that setting is off.

Thanks for confirming, @Jake_Billington.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the issue occurs along with what track is playing. Then respond here with that time + track name, and I’ll make sure we review the diagnostics related to that timestamp.

Hy Dylan. Sounds good.

The track I played in the clip is called ‘DWIG - Again and Again’. The noise is prevalant throughout - rhe clip was taken between 15 seconds and 1 minute and is a good exmaple of it.

Hi @Jake_Billington,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping, for now, you could use the directions found here and send us over a set of logs using a shared Dropbox link.

Sure. Here you are.

Thanks, @Jake_Billington. I’ve passed this along to the technical team for review and I’ll follow up soon when I have their feedback.

Hi @Jake_Billington,

I spoke with the team about their findings here, and they’re hoping you can try a couple things.

First, can you try to uninstalling the realtek audio drivers from your machine? Does that improve anything here?

If not, can you send us RAATServer logs? They’re very similar to getting Roon logs, but you get them from the RAATServer folder instead of the Roon folder.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.