Audio Loading Slowly on ROCK

Seems that I have the same (or it just looks similar) problem.

Core Machine (Operating system/System info/Roon build number)

Rock @ Nuc /Roon 1.8 (build 753)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Gigabit Internet/Ethernet/

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Gustard U16 is connected by USB directly to an endpoint.

Description Of Issue

I had lots of errors “currently not available on T/Q”, “media loading slowly” months before but today I won a jackpot - no track from tidal and qobuz and sometimes even local media files from Nuc internal storage won’t play (no matter if shuffled, inside of a playlist or just single track straight from an album). It reproduced every minute of an every hour today.

It looks like that every single time: a track starts to process, audio path icon appears, processing speed appears but it won’t start playing for 3-5 seconds, track navigation slider looks frozen, still 0:00 on the clock. After 3-5 seconds has passed, it starts playback for 5 seconds and always stops on 0:05 mark then it says “oh there’s some error, it’s not available, it’s loading slowly”. Same even with local files!
All I could find in logs “media is loading slowly”.

I’ve tried to: reboot and reinstall Roon, Rock, router, tried another PC, Mac, cell phones (remote), replugged every ethernet cable, tried playing with DNS and IGMP snooping settings (some DNS changes would help me before but not today), reinstalled my router firmware, rechecked all settings on PC, rechecked DSP, Convolution, cache, buffer, resync delay settings in Roon, even if nothing has changed there from yesterday.

Native applications for Tidal and Qobuz work fine, absolutely nothing to complain about.
Then I’ve searched forums for similar threads, found this one, followed an advice by @noris, renamed my database at Nuc to RoonServer_old and relogged to create a new folder. Woah! That really worked instantly! Everything can be played in any order, just in one click, perfect!

Can I ask you what can I do now? I am trying to add files from RoonServer_old folder one by one to see which one caused so much struggle and now I suspect tidal.db and qobuz.db files - they do make “connectivity” difference when copied back…

1 Like

Hi @Yaroslav_Vasilyev ,

Thanks for sending those logs over and for your report here! I’m noticing dropouts only occurring when you play to your Gustard zone, have you verified if this is the only zone impacted? I would try to use your ROCKs HDMI port to verify if multiple zones are impacted, even if there is nothing connected to it, just check for an error message.

You shouldn’t manually move these db files around as it can cause database instability. I would advise using a proper Roon backup if you want to try to restore to an earlier database version:

Thank you!

Right now it happens on my Apple cellphone playing to its own audiozone, also no luck with Macbook. Same symptoms, 3-5 sec before it actually starts playing (which is already unusual for me - used to be 0-1 sec always), then 5 sec and playback interrupts. a quick screen recording
actually this is what I get suddenly only today but everytime I hit “play” and on every machine.

Nuc is connected to Mikrotik 951-2hnd router by ethernet, my main endpoint PC is wired there too. Looks like:


2 MacBooks, plenty of iOS and Android devices connected wirelessly to Mikrotik

Everything worked just yesterday… I’ve really checked a lot but then just downloaded Tidal and Qobuz apps (PC, iOS) and was able to stream any data seamlessy which makes me think it’s not my network.

I have a backup but the greatest problem for me is that playback only works on a clean library now. If I restore my backup correctly within Roon settings, it rolls out good but I can’t play tracks anymore :open_mouth: thats why I went extreme ways and started to check file by file :smile:

Yes! I found it! In the router logs :smiley: There was a problem in my network connection. Dunno how it happened cause I don’t recall touching this at all, but somehow my NUC negotiated a 10M half duplex connection to a router (why on earth). Changed it to 100M full duplex strictly and the problem is gone!

Sorry for taking your time, cheers!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.