Authorization Issues Migrating To ROCK

Yesterday, I set up Roon ROCK on a NUC7i3bnh. When it came time to restoring from my existing database I had problems. The first problem was that after backing up to a usb flash drive the NUC said the backup file was empty. On my mac the backup folder does not show any contact but get information says the folder is more then 600 MB. The I encountered the , “Not authorized” message. My first attempt at rebooting the NUC from the ROCK web page failed. I then power cycled the NUC. That brought Roon back But I am still getting the not authorized message. To reiterate, when I start my Roon app on my iPad, i get s= screen asking which core I want to connect to. When I choose the ROCK, Iam told I am not authorized to use more then 1 core. When I select my first core, it connects and music flows. Since I have a lifetime license, I am not sure why I should be limited to 1 core or why this is the first place authorizations are mentioned.

I should have proof read my post. The message isn’t that I have more then 1 core, but that only one device is allowed to remote control the core. Either way, things are not working for me just like the other people in this thread. Some help would be good.

A post was merged into an existing topic: Authorization problem with 1 core and 2 remotes

My first core is on a 2011 iMac. I installed the ROCK and it just started to work. It didn’t ask for a license. Since I can’t connect to the ROCK I haven’t had a chance to be asked for a license. The instructions for installing ROCK don’t mention licenses, at least, not before restoring the database.

It has been more then a day since I posted about this problem. I have not seen any useful help. I still have a roon rock that can not be used. It is great that you are working on the problem. In the meantime, do you have any advice for a work around?

Hey Robert – on the iMac, what are you currently seeing?

Try this on any remote on your network:

  • In Settings > General, click Disconnect
  • Select the iMac (if you’re doing this on the iMac, it will say “This Mac - Continue”
  • In Settings > Account, click Logout
  • From Choose Your Core, select ROCK and choose Continue

I think that should do it but let us know if you’re still stuck.

These instructions are not entirely clear.

I first tried following these steps from my iPad. I started roon and it was connected to my first core. I went to settings and selected disconnect iMac. I then got a choose your core screen. I selected the imac core. I then went to settings and chose logout from the account. I then got the choose your core screen and it displayed just the rock. Unfortunately, the connect button was not selectable. Now I can’t connect to either core from my iPad.

I then went to the iMac and tried these steps. When I disconnected, roon quit. I restarted roon and got a screen that had the continue button for the iMac. I went to settings and chose logout from account. I then got a screen that says choose your core with the following options: choose this mac to manage your library and use this mac as a remote control.

Note, this isn’t mentioned in the instructions.

Just to be on the safe side I went to the rock web page and restarted rock. I then chose the second choice, use this mac as a remote control. that sent me to the authorizations screen.
In case you guys don’t know what is on the authorizations screen, the choices are:
go back
get more authorizations
oops, i meant to run as a remote control
contact support
a list of my devices with an unauthorized choice.

I have to say that none of those options produced any useful response.

I did manage to get my first core connected again and I am now listening to music.

After buying a lifetime license, I was definitely hoping to have wonderful software to help me listen to music along with responsive and useful support. I am trying to switch to ROCK so that I can have a small physical and power consumption footprint. Instead I have this reality.

Thanks for bearing with us here Robert – nothing has changed recently in this area of the app, but it certainly seems like there’s some kind of an issue here, whether it’s related to our documentation, or a bug in the application.

We’ll figure out what’s going on here but first, let me clarify a bit about how this works:

  • Roon licenses function like “slots” – most Roon users have one slot (from one license) and a Core needs to use a slot. If you start up a new Core, and there are no free slots, you will need to free one up

  • On the Choose Your Core screen, you should see all the Cores on your network, whether they are logged in, or authorized (or neither).

So the goal here is to ensure that the iMac is only running as a Remote – once the iMac is no longer occupying a “slot” you’ll be in good shape. All you’ll need to do is log in ROCK and you’re done.

Having said all that, I want to focus on this:

Are you sure the Connect button did nothing even after you selected ROCK like this:

I want to make sure we get this working for you. Can you let @support know exactly what you're seeing on your devices now?

If you can tell us what devices you have and what you’re seeing on each one, we can be more specific about what to click, and where.

Thanks Robert!

Thanks for the note.

I don’t have time right now to look into this again, but my =
recollection is that your summarization of what I did is correct. I =
would have said the connect button was grayed out but the actual color =
was more like a pale blue.

Also, thanks for explaining about the cores and slots.

I decided to try again. This time I stopped the rock. I then disconnected the roon core. Then I logged out of the iMac roon. I then started the rock. It started and got to a screen that asked for the location of the music library. I decided to gamble and gave it the usb flash drive with the backup file. It then went to the authorization screen.

This morning I decided to try again. Except when I stopped the rock It never fully stopped. I have a screen that says “Stopped Roon server. Waiting for it to shutdown” Apparently my choices are to wait until it decided it is shutdown or power cycle the nuc.

Any chance a roon employee will give me advice on whether I should power cycle the nuc or wait until rock decides it is done shutting down? It has been deciding for over 4 hours.

A post was split to a new topic: Endpoint + Playback troubles

Oh, power cycle the thing - that’s what I do if it tries that on me. Show it who’s the master. (I’m not a Roon employee, BTW).