Authorization not recognized

I have 2 authorizations ( 2 lifetime memberships), one for my office system and another for my home system - 2 different physical locations. Core machine at office is Win 7 Ultimate PC, current version. Home core is on Sonic Transporter, Linux. All OS and Roon software is current - or at most 1 update behind.

Both networks are hardwired CAT 6 to Bryston BDP3 Digital Media Player at home and to PS Audio DirectStream DAC Bridge II at office. I know the DSD firmware is most current and but am not sure about the Bryston.


Audio devices - see above. DSD bridge II is connected internally to DAC section. BDP 2 is connected by AES/EBU to Bryston BDA 3 (DAC)

When I sign in at home or at office I get the following meessage: Your Roon membership allows you to authorize up to 2 devices…
You have already authorized 2 devices, so if you want to use this Core …unauthorize a device below or get an additional membership…

Yesterday at home the “Your Devices” list included “sonictransport” and “DSD Bridge II”. This is the system where the core is on the sonic transport; but evidently that is not recognized as “authorized”.
Yesterday I unauthorized the “sonictransport” in the Your Device list and the sonictransport was then recognized and functioned properly.
Today, at the office, “Your Device” section listed sonictransport twice. I unauthorized the first “sonictransport” on the list and the core immediately recognized the DSD Bridge II. and functioned properly.
I would prefer to skip this unauthorize/ authorize step every time I want to listen to something. Other than this, and the general difficulty in getting customer service as a computer dummy, Roon is awesome!


Hi @crmanitly,

Thanks for reaching out.

This sounds strange to me, can you please share a screenshot when/if this happens again?

Thanks for the prompt reply, Noris. Looks like problem is solved - although I’m not exactly sure how!

I went back and forth home to office once or twice and then decided to start taking photos of screens. The attached series of photos (I hope they attach anyway) are from last night at home. The sequence of screens displayed was a little different in the past and --voila!, it ended in victory!
I came in to office today and Roon loaded up here perfectly too,without needing to select Core or log in.
I have not tried Home again but last night I went in and out of Roon several times without a problem. I’ll reply again here if the problem returns.
By the way, when looking at the photos, “Home PC” is the PC at my office. It was moved to the office a couple years ago and Roon had been running on it normally, recognizing the DSD Bridge (used at office) all along.
Oh, that’s another system thing I didn’t make clear. At the office the Core and Controll are on same machine. AT home the Linux Core is controlled by Roon on a Win tablet

Hi @crmanitly,

Thanks for the update. It looks like your screenshots didn’t attach properly, you will want to use the “image upload” button on the forum:

Since it sounds like the issue is gone, do feel free to send the screenshot when/if it occurs again, thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.