Authorization problem with 1 core and 2 remotes

So far I haven’t had any issues in terms of authorization / un-authorization (I have 1 Roon Core and 2 remote controls: phone and laptop). Today I tried to play some music using the Roon app from my phone (Android) and got a warning saying:

Your Roon membership allows you to authorize 1 device to manage your library … etc … below this warning there are couple of options:

-> Get More Authorizations
-> Oops, I meant to run as a remote control
-> Contact Support

Also I can see here my Roon Server listed and a unauthorize button.

When I clicked on the second option (Oops) I see my Roon Server (Linux) but when I click on it … it goes back to the first warning ???.

Initially I thought it was an issue with the Android app … but in my laptop (win) is the same. Now this is bugging me even more because until yesterday i didn’t have any issues. maybe a recent update in the core? …

Please any help will be appreciated.

@support Tagging support in for you :slight_smile:

Thanks @Paul_Whittaker
Hi @support … any assistance please?

Hi @Cesar_Sanchez ----- Thank you for the report and sharing your feedback with us. Sorry to hear of the troubles.

Moving forward, to help us properly evaluate this issue you are experiencing may I kindly ask you for the following:

  • Please provide the make/model/spec of the device hosting your Roon core.

  • Since noticing this behavior have you tried reinstalling the application on the mentioned remote devices (i.e “remote controls: phone and laptop”)?


My Core is in a Linux box running Centos 7.3 … 16 CPUs / 16GB RAM / 250GB SSD - No, I haven’t tried to reinstall anything yet. Should I?

I just tried to uninstall/install the app in my phone and same results.

Hi @Cesar_Sanchez ----- Thank you for the follow up and sharing your observations after having reinstalled the application on your Roon remotes.

Moving forward, while it may seem elementary, and my assumption to this question will be, “yes” :innocent: have you tried rebooting the Linux box running your core yet?

Furthermore, I will be enabling diagnostics on your account so our techs can try to get a sense as to what could be causing this behavior. What this action will do is automatically generate/upload a diagnostics report directly to our servers which will contain a set of your Roon logs.


OK … so I just restarted the core and now is working again … ?? … Not sure what happened. Can you explain this issue?

Hi @Cesar_Sanchez ---- Thank you for touching base with us and sharing your observations after having rebooted your Roon core. Appreciated.

It’s tough to say what the exact cause of the issue was here. We are going to look over the diagnostics report and see if we can determine that. Have things remained stable?


Now I am getting the “Authorizations” error message also. I have been updating the support thread pertaining to the issue people are having using android clients. So now its is not just the annoying fact that all of my android devices sometime won’t connect to the Core, now Windows and Android devices are unable to use Roon. Looking like $500 NOT well spent.

Core 1.4 running on QNAP. Remotes: Pixel 2, Galaxy tab s, Shield Tablet and Windows 10 PC.

I have restarted the core several times and uninstalled Client from Windows PCs and rebooted and still getting the same error. The client sees the QNAP/Core but when I click connect it always gives the Authorization errors.

Rebooting the QNAP resolved the issue.

After stopping/starting the Roon Core on my QNAP I get the “Authorizations” error and “connection refused” in the Core logs for the clients trying to connect. Are there other dependencies Core uses that need to be restarted also? Rebooting the NAS every time this happens is not a viable option for resolving this issue.

Hi @Eric and @support … so today i got the error again (first time after this was reported) but even after restarting the Roon Server I still can’t logging from any device. Bummer all day without being able to use it.
Any advice?

Hi @Scott_Muckleroy and @Cesar_Sanchez ----- Thank you both for your feedback and more importantly, thank you for your patience here.

Moving forward, I have enabled diagnostics on your accounts so our techs can try to determine what could be causing this behavior to occur. What this action will do is the next time the application is active on your core devices a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded directly to our servers.

Once the mentioned reports have been received I will be sure to update this thread so you both know that we have them and then I will swiftly pass them over to the team for further analysis.


I’m seeing this in the logs when trying to connect:

01/26 17:46:12 Trace: [push] connecting to
01/26 17:46:12 Trace: [push] connected
01/26 17:46:12 Trace: [raatserver] [RaatServer DESKTOP-8EU5IAJ @] connecting (attempt 2)
01/26 17:46:14 Info: [brokerserver] Client connected:
01/26 17:46:14 Trace: [SOOD] Adding User IP
01/26 17:46:14 Trace: [raat] [sood] Refreshing device list
01/26 17:46:14 Trace: [raatserver] [sood] Refreshing device list
01/26 17:46:14 Trace: SENT NONFINAL DistributedBroker.ConnectResponse={ BrokerId=85d3e3ef-2a50-4323-bbf0-28918f945772 BrokerName='wolverine1' }
01/26 17:46:14 Trace: SENT NONFINAL DistributedBroker.UpdatesChangedResponse={ IsSupported=True WasJustUpdated=False Status='UpToDate' HasChangeLog=False CurrentVersion={ MachineValue=100400298 DisplayValue='1.4 (build 298) stable' Branch='stable' } }
01/26 17:46:14 Trace: [push] restarting connection (Unable to read data from the transport connection: interrupted.)
01/26 17:46:14 Trace: [push] retrying connection in 49396ms
01/26 17:46:17 Info: [stats] 4631mb Virtual, 326mb Physical, 79mb Managed, 0 Handles, 61 Threads
01/26 17:46:22 Trace: [raatserver] [RaatServer DESKTOP-8EU5IAJ @] client connection failed. Retrying in 750ms
01/26 17:46:23 Trace: [raatserver] [RaatServer DESKTOP-8EU5IAJ @] connecting (attempt 3)
01/26 17:46:23 Trace: [raatserver] [RaatServer DESKTOP-8EU5IAJ @] connected
01/26 17:46:23 Trace: [rnet/RnetJsonClient] SENT {"request":"enumerate_devices","subscription_id":"0"}
01/26 17:46:23 Trace: [rnet/RnetJsonClient] GOT NONFINAL {"status": "Success", "devices": [{"device_id": "default", "name": "System Output", "type": "wasapi", "is_system_output": true}, {"device_id": "{}.{0416f880-57c5-4a97-b9bc-ce597e353417}", "name": "Realtek High Definition Audio", "type": "wasapi"}, {"device_id": "{}.{3178e944-8daf-47e3-8c17-e7f89f738812}", "name": "Jabra Link 370", "type": "wasapi", "usb_id": "0b0e:245d"}]}
01/26 17:46:23 Info: [raatserver] GOT DEVICE 0ccdef27-11f2-4a8c-8e99-83b7864a9ca9::default Type=wasapi Name=System Output
01/26 17:46:23 Info: [raatserver] GOT DEVICE 0ccdef27-11f2-4a8c-8e99-83b7864a9ca9::{}.{0416f880-57c5-4a97-b9bc-ce597e353417} Type=wasapi Name=Realtek High Definition Audio
01/26 17:46:23 Info: [raatserver] GOT DEVICE 0ccdef27-11f2-4a8c-8e99-83b7864a9ca9::{}.{3178e944-8daf-47e3-8c17-e7f89f738812} Type=wasapi Name=Jabra Link 370 UsbId=0b0e:245d
01/26 17:46:24 Trace: Successful POST response from
01/26 17:46:24 Trace: [push] connecting to
01/26 17:46:24 Trace: [push] connected
01/26 17:46:32 Info: [stats] 4631mb Virtual, 326mb Physical, 79mb Managed, 0 Handles, 65 Threads

What do you guys see? I’m not able to use Roon since the morning.

Not sure why I’m getting this:

[push] restarting connection (Unable to read data from the transport connection: interrupted.)

But similar message when I try to use my phone (android).

Hi @Scott_Muckleroy and @Cesar_Sanchez ----- I wanted to touch base to let you both know that I have received the mentioned diagnostics and have passed them over to our techs who will be evaluating the information in the report.

Furthermore, can you please verify for me if your Roon core was hosted somewhere else previously, and if this is indeed the case can let us know what steps were taken when you migrated to the new machine and verify that all steps found in our knowledge were followed. Particularly the final step in the process.


I did migrate it but long time ago (~6 months) and yes did the procedure and didn’t have any issues until the first ocurrence of this issue and then today’s.

Eric, I reported this same issue [twice] in the QNAP section. Same endless loop of being unable to authorize.

In my case, after the first episode I was stable until the next build update at which point it came back with a vengeance.

@Eric today Roon is back to normal. Did you guys find anything? These episodes are making Roon very unreliable. I was 2 days with Roon down.

Thank you for the follow up @Cesar_Sanchez and sharing your latest with me. I am currently waiting on feedback from the team in regard to the received diagnostics reports but as soon as I have an update I will be sure to follow up immediately.

Cesar, have things remained in stable state?