Authorization problem with 1 core and 2 remotes

Eric, I reported this same issue [twice] in the QNAP section. Same endless loop of being unable to authorize.

In my case, after the first episode I was stable until the next build update at which point it came back with a vengeance.

@Eric today Roon is back to normal. Did you guys find anything? These episodes are making Roon very unreliable. I was 2 days with Roon down.

Thank you for the follow up @Cesar_Sanchez and sharing your latest with me. I am currently waiting on feedback from the team in regard to the received diagnostics reports but as soon as I have an update I will be sure to follow up immediately.

Cesar, have things remained in stable state?


7 posts were split to a new topic: Authorization Issues Migrating To ROCK

@Eric so far yes … but since I don’t know what is causing the issue is really something that your team needs to look into. Also I’m not the only one having issues as per Rober’s comments that is STILL with Roon down.

Core has not been moved. This is the original install on the QNAP.

William- Rebooting the QNAP resolved the issue for me, not that that is a good solution.

Just so everyone knows, we are doing some testing on this issue, and while we haven’t found consistent steps to reproduce the issue, we did see these symptoms once in our testing today.

Obviously, we have some more work to do here. If the steps required to trigger this issue were simple, we would already have those steps in a ticket with our developers.

For now, we are going to continue working on getting this crisp, and we will let everyone know when we’ve made some more progress here.

If you experience this issue again, please let us know. Additional details about where your license originally ran, how you moved it to the current device, or any other details about how you set up your Core or license would be appreciated.

Thanks for your patience everyone!

I started to have this same issue recently on my Linux Roon Core install. It’s the same install I’ve been using for many months. Any suggestions on a resolution or data I can provide to help resolve my issue or identify the cause for others?

Hi @Jamie327 ---- Thank you for chiming in and sharing your feedback with us. Sorry to hear of the troubles.

The first thing I would suggest trying is rebooting your core machine and see if that helps. If it does not, as mentioned Mike’s previous, please provide the following information:

“If you experience this issue again, please let us know. Additional details about where your license originally ran, how you moved it to the current device, or any other details about how you set up your Core or license would be appreciated.”


Rebooting definitely doesn’t help as I’ve done it multiple times. This is the same installation I’ve had since I added my license when I first purchased it. The only thing I would mention about the setup is that this is a dedicated Linux virtual machine for the Roon Core. It has no other purpose.

Sorry for the trouble here Jamie. What device are you seeing the error on? What exactly are you clicking when you’re stuck here?

It’s happening on iOS devices as well as OS X client.

When I open the client, I click “Connect” under the Roon Core server I want to control. That’s when I get the Authorizations error and click “Oops, I mean to run a remote control” which takes me back to the list of Cores again where the loop continues if I click Connect.

Hey Jamie,

We’re enabling some diagnostics for you so we can get a better understanding of what you’re seeing.

When you’re on the Authorization screen, are you seeing other devices listed there for you to unauthorize?

Before you were running Roon on this VM, where did you run your Core? Another VM, or a different machine altogether? Did you do a backup and restore to migrate to the VM?

1 Like

Hi @jamie327 ----- Following up to let you know that the we have received the mentioned diagnostics and I will be preparing your ticket for evaluation by a member of our tech staff.


Thanks. No other devices are listed on the authorizations screen.

I wasn’t running Roon on any other computer. This is where it was installed and licensed.

Can you take a screenshot of the Authorization screen and paste it here ?

1 Like

FWIW, I ended up de-authorizing the Roon Core and restating and everything seems to be back to normal. Can’t explain any of it but that seems to have worked.

A post was split to a new topic: Switching over from ROCK to RoonServer - Authorization warning


Was there a resolution to this?
I just had the same issue and the only way out the loop was deauthorize my core and that worked and got me in. From there I went under settings and the real correct core is still selected.
The software then seemed to want to reload all the artwork / database.
It seems OK now but I am worried still that something isn’t right.


9 posts were split to a new topic: Roon Authorization Issue