Automatic changing of sample rate

I’m using Roon with 2 DACs (not at the same time) - a Grace Audio m900 and UAD Apollo 8.

Neither DAC will automatically change its sample rate to match the song being played by Roon. I’m using Nucleus to send signals to my Mac, where the DACs are connected via USB.

Thanks for any help!

It sounds like you may be using System Output rather than Built-In Output, and the OS mixer is downsampling. See this post …

It would be really helpful if you could share a screenshot from Settings > Audio showing those DACs. Thanks.

1 Like

I did not have Exclusive Mode turned on. Works great now, thank you very much!


Well, here’s a complication: I also use Sonarworks Reference 4 calibration software. When I choose Sonarworks as the output device in Roon and set it in Exclusive Mode, no sound comes out but the song plays. Sonarworks normally sends the signal to the Grace m900 and I’ve tried it with the Grace set to Exclusive and Off and neither setting works. Any idea if this is fixable?

Hey @Anthony_Saracino,

It’s great to see that with @Martin_Webster’s help (thanks a bunch for helping :pray:) the first part of this was resolved.

Is the latter part still an issue? Can we still help?

I’m sorry we took this long to reply - I wish this wouldn’t have been so :pleading_face:

1 Like

Hello Rebeka,

Yes, it’s still an issue as Sonarworks does not seem to work in Exclusive mode. I’m not sure that’s a Roon issue, but it would be great to figure out a solution for using room correction software with Roon.

Thank you.