Autostart Roon in Windows 10

Hi Rugby I need some help I just installed win 10 but I would like to autorun Roon when I start my pc so I don’t allways have to open my screen but I cant find the way please help. thanks

1 Like

Hi Dimitris,

I shifted your post into it’s own thread. @rugby may have further comment but I think you’ll find what you need here.

This can be done as Russ helped me set it up on my machine. How is beyond my pay grade.

Hah - just done this for our HTPC. Steps are as follows:

  1. Go to the folder where the Roon executable is kept; e.g.:
    C:\Users\Username\AppData\Local\Roon\Application (where “Username” is the name of the account used for your Windows)
  2. Right-click on the Roon executable and choose “Send to Desktop”, i.e. create a shortcut for Roon on the Desktop.
  3. Copy the Shortcut.
  4. Paste the shortcut link into: C:\Users\Username\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

That’s it. Reboot, and Roon should autostart when the Windows Desktop opens.


Oh, and if you want to autologin when the computer is powered on, then Method 1 described here is what I use:

Also the task scheduler is a good option, winKey+X, G -> Computer Management, then select “Task Scheduler”
There you can also set more advanced start options, like when to start it (delay time, only when idle, etc), where to start it (like only when the computer is at home)

Thank you all for your help.

Hi I have tried this and there was already a roon shortcut in the location, however when I start windows roon does not autostart

Can anyone suggest other alternatives? Running Windows 10 64bit here

Edit, sorry looking in wrong place

this is great and works on my Desktop/Server
however for the REMOTE Win10 tablet
it does not launch … what could be the issue
I have double checked it in taskmanager /STARTUP and says ROON is ENABLED
along with Win Defender on these two are in Task Manager STARTUP TAB
however i have booted rebooted and the 12"’ Win10 Tablet will NOT START ROON the only way is i have double click the Desktop shortcut to AUTO START ROON as a REMOTE
Am i missing something !!!
thanks i hope you can help…
this is a mystery… or…
thank you in advance…

It could be because you are presumably using the Windows 10 tablet in Tablet mode. In this mode, the Start screen is what displays when you sign in to Windows. Any Startup applications will be started, but won’t be brought to the foreground of the screen. You need to touch the Task View icon in the Taskbar to see and choose between the active programs that you want to bring to the foreground.

That, at least, is the behaviour that I am seeing on my ThinkPad 10 tablet, which is running Windows 10. I’ve put the Roon shortcut in the Startup folder (as described here). Roon does get started when I sign in to Windows, but I need to use the Task View icon to choose between my running programs and bring the Roon window up.