B&O Beoplay A9 failed to play

Hi all

I’m just setting up Roon to our home set up. All is working fine except for the Beoplay A9 (via AirPlay/Airplay2) … when trying to play a track, it stops after 1 second. Please advise how to correct it. Cheers.

Hi @duomono,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Additionally, please confirm the following:

  • Do you have other Airplay endpoints? Are they working okay?
  • Do you get any error messages in Roon when trying to play to this device?
  • Can you share a screenshot of Device Setup for this device?

Hi Dylan

I’ve set up …

Roon Core
Mac Mini 3.6GHz 6 Core
Music files via Synology NSA

Roon Server
Mac Mini 2.6GHz i7 to Chord QBD76
B&W Zeppelin Air x 2 (via AirPlay)
B&W A7 (via AirPlay)
HomePod (via AirPlay … stereo mode not working)
B&O Beoplay A9 (via AirPlay connects but doesn’t play)

So all are playing except the A9. I’m aware that Roon has yet to make HomePod stereo works (please do!). There’s no error message.

Looking forward to your help. Thank you.

Hi @duomono,

Just to confirm, if you play to this device via Airplay from the same Core machine from sources other than Roon do things work okay?

Can you share a screenshot of Device Setup for this device?

Is there any difference in how this device is connected to the network?


Still struggle to get the A9 playing … I’m been using my iPad/Roon (via Airplay) to stream to the A9 … will be great if can be steamed directly. Any help will be greatly appreciated.

Thanks for the follow up, @duomono!

Have their been any changes to your setup at all in the time since we last spoke?

Is Roon fully up to date? Is the A9 up to date?

Do you have any other Airplay endpoints you’re able to play to? Do they work okay?


We are really happy with the Roon platform… Roon is updated. The Beoplay A9 has been updated too and uses Airplay2 with no problem at all. This is probably the only problem we have (other than hoping Roon would support HomePod Stereo setup).

The list you see below is all working with AirPlay and Roon except the Beoplay A9.


Hi @duomono,

Just to clarify, the failure here is that Roon appears to play but no sound is produced by the B&O, correct?

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


What happens is when I select the A9 (Sunroom A9) to play on Roon, it attempts to play for less than a second and stops. You’ll tap on the play icon, then it returns to a stop icon. All the other players are working perfecting fine except for the A9. The A9 also works perfectly fine with Airplay2.

Test at 11pm (Melbourne time). Thanks.

Hi there,
just a quick note - unfortunately the Bang & Olufsen software is often a case in itself.
That’s why I sold my Beoplay A6.
I still have a B & O Beosound 2, also with a lot of software issues. At least Chromecast works (again), so I can use the BS2 with Roon.
have you ever tried to connect your A9 via ethernet?
Or have you ever tried to restart the A9 via B & O app (under troubleshooting)?
And, for my BS2 at least, it always helps to take out a function via the app and then reconnect it. Airplay in this case.
Just in case … at least I have been dealing with B & O and Qobuz software issues for 4 years now :slight_smile:

The B & O customer service, however, was at least more than satisfactory for me, unlike the tricky software, I can recommend it.
Here is also a link:


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.