B1191/B129 ARC "Can't connect to your Roon Core" message both on home wifi and on cell network [Resolved]

Thank you for your reply. Could you, please, do this

It’s going to be a good data point here.



Will do tonight. Can obviously also try on the iPad

Thanks! Looking for to hearing about the results.


Results are in. For now I only installed ARC on the Samsung Galaxy Tab, on my home wifi. It found the core, synced, no issues. I guess that’s good enough to show that there is no major issue with the core nor with my account or its ARC credential magic in the Roon cloud.

I would say next step is to make the Fairphone’s ARC find my core again in my home wifi. I am pretty sure that after that works, the external connection will be just fine. Agreed?

So I guess the question is how. I can just reinstall ARC on the Fairphone and see if it works again. If it does, the evidence for why it crapped out for no obvious reason will be gone, I suppose. (If it still doesn’t work, we have narrowed it down to something with the Fairphone). Do you want to get anything off my Fairphone (I don’t know, some ARC files, logs, whatever) before I try that?

Or any other suggestion? Please let me know your preferred next step

Thank you for your reply, @Suedkiez. I think good next steps here will be the following:

  • While you are still in that state, collect ADB logs (Android OS level logs) from your Fairphone. Here’s how you can do this:

Connect your PC to Android phone and install ADB (instructions are here (all platforms)). Then:

  1. Type adb shell in terminal
  2. Type logcat v (ref: Ferramenta de linha de comando Logcat  |  Desenvolvedores Android  |  Android Developers)
  3. Reproduce the problem and let terminal print logs for 3-5 more seconds
  4. Select output from the moment you started the reproduction of the bug till the very end
  5. Upload the log here and let us know once you have done so – https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external
  • When it’s done, if you are OK with that, I’d ask you to reinstall Roon ARC on your device affected by the issue and see how it goes



1 Like

Hey @Suedkiez, @ivan
Reading your answer, something came to mind from an old thread when ARC was new to early access:

Because I was thinking at the time whether a Fairphone could be something for me, I asked myself what this bug was all about?
Maybe you still know and it could be useful in clearing up this matter here.

This bug was fixed by Fairphone months ago and was something completely different. Note how my old post you linked was talking about cell data not working. Here in this current case, the most simple incarnation of my current issue is that the Fairphone has suddenly stopped finding the core on wifi as well, as I have written several times. Until it works on wifi, none of the port forwarding and cell network stuff matters, let us deal with that later if necessary :slight_smile:

(In the old issue, my then-new Fairphone did not get a cell data connection on the Vodafone network at all, using the default APN settings on the Vodafone SIM. However, as it turned out eventually, creating a new APN entry with the exact same settings and using this, it worked. It was super annoying at the time because of additional complexity while sorting out the port forwarding with VF (or rather the full-range port block imposed by VF apparently accidentally, if I remember correctly that this was the issue at this particular point in time :rofl:). Baffling too, as Vodafone was also selling Fairphones in their mobile contracts and did not know about the issue when I called their support, but the Fairphone forum was full of new FP owners on VF experiencing this issue. Some forum members had already identified the APN settings as a cause, but had not fully understood it. Then it took me half a day of dicking around in APN settings to figure out the details and make it 100% reproducible (there had to be a very specific sequence of doing things), and to report the findings to Fairphone. I think it was some issue with reading the APN supplied by VF from the SIM, so the same settings in a new APN entry worked around it, before it was fixed)

(If you considered a Fairphone, by the way, after this initial obstacle I am really happy with it. There is another cosmetic issue I reported that I still find mildly annoying but YMMV: They show traffic arrows in the notification bar top right, next to the cell network icon, but they forgot to reserve space for them. So when the traffic status changes, the other notifications jump a bit when the traffic arrows appear or disappear, i.e., all the time when you do something on the phone. If this doesn’t bother you, it’s a fine phone. No featherweight though)

1 Like

I’ll supply the ADB logs tomorrow or so

1 Like

Don’t rely on UPnP, what you can try to do is set a static IP to your ROCK and forward the ARC port. Buying a static IP for this purpose was unnecessary, The only reason to want dedicated IPs is if you run multiple servers outside of your LAN. In this case, opening a port would have been just fine. I find it interesting all your devices connect to ARC but the Fairphone. Sounds to me as if your router is not able to open traffic for that device on that port because it might not have the same IP as before. And it can be that your mac is still in ARP and causing the conflict. Do you have any sticky Macs set up for that device?

Please let’s stop this. I know what I am doing. The problem has nothing to do with ports as long as the ARC app does not work in the wifi. And the port forwarding is from the router to the core, the endpoint has nothing to do with this. And no, I had to rent an external IP because Vodafone otherwise uses DS Lite addresses that can’t be port forwarded (tunneling IP4 through IP6). And the port is open just fine because an external port scan shows it to be. Anyone wanting to help with this issue, it’s appreciated but please first actually read what I wrote in this thread.

The log is uploaded, good luck and thanks! :slight_smile:
I uninstalled and reinstalled ARC on the Fairphone, it found the core, synced, no issues, all good.

Thanks, @Suedkiez, I will pass this info to our dev team.


You know what you’re doing but rely on UPnP okay…

Hi, @Suedkiez, quick question here. By any chance, were you restoring backups around during the time period that before this state:

From Christmas to 13 days ago, I was traveling and ARC worked. The next 7 days I didn’t try to use it and didn’t have the ARC app open. Then I tried 6 days ago and had the same messages (except it was saying that Core last seen 7 days ago, obviously). I thought maybe it was because of B116 not coming through the Play Store, so I didn’t report.



Hmmm, good point. I actually did but had forgotten about it. Restoring the backup was not because of any problem but because during vacation a new USB stick came into my possession and I thought I’d use this for additional backup redundancy.

So some time after returning home, certainly not before Dec 29 and probably between Dec 30 and Jan 1, possibly some days later, I attached the stick to the ROCK NUC for a nightly database backup. (Previously, backups had only been done to the NAS, which doesn’t run every day)

Some days after, and indeed this could possibly coincide with the appearance of the ARC issue, I tested the backup by restoring the latest one, and that went without issue. As I wasn’t using ARC during that time, I wouldn’t have immediately noticed a sudden ARC failure, and when I did notice it, I had forgotten all about the restoring of the backup.

@ivan I happened to see this now about the remote not connecting after a backup restore, Android Remote Connection problems to Roon Rock [Ticket In] - #18 by Olaf_Jungen
Don’t know if related but just wanted to mention again that none of my remotes had this issue, just ARC

Thank you for your reply, @Suedkiez!

As for your last, it’s a different bug that affects Roon Remote, unfortunately :frowning: Nevertheless, we have 2 separate tickets for both issues and I hope our dev team will be able to tackle them down soon.



1 Like

I just saw that it was marked as resolved in the title, so thank you very much!

Roon ARC does not “work”, anyplace, anytime. My iPad, iPhone all current updates). “Poor Connection Try Again”.I have a VERY strong wireless signal, 5’ from router. Same message when trying on iPhone. Roon works perfect, except ARC. Thanks

“Poor connection, try again” was fixed for many people by going to ARC > Settings and clicking Reset.

If this doesn’t help, open a new topic for your issue. If you run the earlyaccess builds, open the new topic in #early-access, else in #support. The issue in this topic was a very specific one and with a different error message that yours, which occurred after restoring a backup and was resolved.