B1191/B129 ARC "Can't connect to your Roon Core" message both on home wifi and on cell network [Resolved]

Don’t rely on UPnP, what you can try to do is set a static IP to your ROCK and forward the ARC port. Buying a static IP for this purpose was unnecessary, The only reason to want dedicated IPs is if you run multiple servers outside of your LAN. In this case, opening a port would have been just fine. I find it interesting all your devices connect to ARC but the Fairphone. Sounds to me as if your router is not able to open traffic for that device on that port because it might not have the same IP as before. And it can be that your mac is still in ARP and causing the conflict. Do you have any sticky Macs set up for that device?

Please let’s stop this. I know what I am doing. The problem has nothing to do with ports as long as the ARC app does not work in the wifi. And the port forwarding is from the router to the core, the endpoint has nothing to do with this. And no, I had to rent an external IP because Vodafone otherwise uses DS Lite addresses that can’t be port forwarded (tunneling IP4 through IP6). And the port is open just fine because an external port scan shows it to be. Anyone wanting to help with this issue, it’s appreciated but please first actually read what I wrote in this thread.

The log is uploaded, good luck and thanks! :slight_smile:
I uninstalled and reinstalled ARC on the Fairphone, it found the core, synced, no issues, all good.

Thanks, @Suedkiez, I will pass this info to our dev team.


Ivan

You know what you’re doing but rely on UPnP okay…

Hi, @Suedkiez, quick question here. By any chance, were you restoring backups around during the time period that before this state:

From Christmas to 13 days ago, I was traveling and ARC worked. The next 7 days I didn’t try to use it and didn’t have the ARC app open. Then I tried 6 days ago and had the same messages (except it was saying that Core last seen 7 days ago, obviously). I thought maybe it was because of B116 not coming through the Play Store, so I didn’t report.

Thanks!


Ivan

Hmmm, good point. I actually did but had forgotten about it. Restoring the backup was not because of any problem but because during vacation a new USB stick came into my possession and I thought I’d use this for additional backup redundancy.

So some time after returning home, certainly not before Dec 29 and probably between Dec 30 and Jan 1, possibly some days later, I attached the stick to the ROCK NUC for a nightly database backup. (Previously, backups had only been done to the NAS, which doesn’t run every day)

Some days after, and indeed this could possibly coincide with the appearance of the ARC issue, I tested the backup by restoring the latest one, and that went without issue. As I wasn’t using ARC during that time, I wouldn’t have immediately noticed a sudden ARC failure, and when I did notice it, I had forgotten all about the restoring of the backup.

@ivan I happened to see this now about the remote not connecting after a backup restore, Android Remote Connection problems to Roon Rock [Ticket In] - #18 by Olaf_Jungen
Don’t know if related but just wanted to mention again that none of my remotes had this issue, just ARC

Thank you for your reply, @Suedkiez!

As for your last, it’s a different bug that affects Roon Remote, unfortunately :frowning: Nevertheless, we have 2 separate tickets for both issues and I hope our dev team will be able to tackle them down soon.

Thanks!


Ivan

1 Like