B1218 ARC stopped working after updating from B1216 (also with B1226)

Roon Core Machine

Core resides on sonicTransporter i5

Networking Gear & Setup Details

Synology RT2600ac router
Netgear unmanaged switch
Core connected via ethernet

Connected Audio Devices

iPhone X connected via WiFi and 4G

Number of Tracks in Library

47000 tracks

Description of Issue

I was using ARC on my iPhone 8:30-9pm yesterday evening (GMT) without issue

Overnight I think Roon then automatically updated to the latest build, on both core and remotes.

I opened the ARC app this afternoon to download an album before going out and message “Core last seen 15 hours ago” displayed. The app will not connect to the core, or let me play downloaded material.

I have now tried the ARC connection test in Roon settings, but the test never completes; no message is displayed, just the circle of death.

I have checked that the router config is still present, and it is (as per attached)

I have rebooted and restarted the Core and iPhone, but this has made no difference.

There have been no changes to my network overnight that I can see.

Roon itself operates fine.

I’m looking for help as to what to try next


Almost identical issue here - Core on W10 pc hard wired to Virgin Hub 3.

I’ve followed almost exactly the same diagnostic steps, including restarting the router.

Also looking for ideas… :wink:

1 Like

Hi @Stampie,

Your report suggests the symptoms of an authentication mismatch - does a reinstall of ARC on the iPhone by chance restore connectivity? Other possibilities include a certificate expiration or firmware update on the part of the router, or some port reservations that have been put in place by the ISP and are blocking the port test. If you restart the router, does that allow the port test to complete?

We’ll proceed from there if not, and I’m sorry to hear you’re experiencing issues.

@AndyR, are there any diagnostics displayed in Roon → Settings - >ARC, or is the port test similarly hanging for you?

Hi @connor

No diagnostics displayed here either. A router restart didn’t help.

Hi @connor, none of your suggestins have made any difference.

The ARC test in roon settings still fails to complete.

I removed the ARC app and reinstalled from Test Flight - I can log in, but it will not connect to the core.

There has been no changes made to the router config at all. the only change has been the update to Roon.


I’m also having the same issue cannot connect to the core via wi fi while traveling or on my home network I m on Fios and use a sonic transporter I re booted router reinstalled arc with no success

Hi @connor @Stampie

I have found that I can break out of the port test hanging by turning off upnp in the router, at which point it completes the test, indicating a fail, and flags some diagnostic text as you would expect. It will hang again if upnp is reenabled.

BUT if I leave upnp disabled and manually configure port forwarding, the test completes, and ARC works.

I used a different port number to the one previously selected by Roon; I didn’t try all permutations of same/different, and I wasn’t especially consistent with stoping and restarting Roon Server during testing.

ARC tested on iPad house WiFi and Android phone house WiFi and cellular 4G; Android ARC is still on the previous build.

Automatic port forwarding configuration was previously working ok.

I don’t think I changed anything other than updating to 1216, but I have no control over what Virgin might have done!

Thanks @AndyR for all the testing. I’ve tried the same steps myself and have had the same results :slight_smile:

I also re-enabled UPNP, but kept the new port number. ARC is still working and the test passes as well.

This doesn’t explain what the root cause is, but feels like something at the Roon end with the latest release.

I’m surprised more people aren’t having this problem tbh.

So, @connor , what more would you like us to do to help find the root cause? This solution is really just a workaround and not something a user should have to do.


PS. Andy, my ISP is also Virgin, but the modem only in modem mode.

Thinking on this more, I wonder if just changing the port number would sort the problem. Obviously, it’s too late for us to test this opti0on, but perhaps the next person who comes along can try it

The issue might be limited to people on early access with a Virgin Hub 3…

Not sure we could have just changed the port number - I had to disable upnp to break the loop, then I’m not sure there was an option to select a port number in Roon before turning upnp back on. Sequencing is likely crucial, and I’m not sure I want to beak it again to find out!

HI @AndyR and @connor ,

So just installed the new build 1218 and ARC is broken again. The ARC test fails as well.

So, I disabled UPNP on my router, rebooted my Core and switched UPNP back on to fix it. I did not need to reboot the core again or change the port number.

As this has now happened on two consecutive releases I believe this rules out coincidence, and requires further investigation to see what’s causing it.


1 Like

Hmm. No issues here after update; although I have left upnp disabled.

1 Like

Thanks for this hint…that could be me! I’m out and about now but have the same symptoms after updating - I’ll make use of your experience in trying to fix it. (BT hub as modem for me with Unifi Dream Router).

This just worked for me. Verizon FiOS.

I followed this exactly and it fixed my problem! Verizon FiOS.


Same here on Fios Router
Disabling UPNP, while not clearing out The Port forward and Static IP settings Arc had previously set allowed the arc test to pass. Arc is now working on mobile app.
I have not tried re-enabling. Don’t want to risk breaking it again!

Hi Guys, same issue with Virgin Hub 3 only after the last update this happened, thks for the advice.

Having the same problem here in Germany… ARC was working flawlessly over the last months, and all of a sudden it can’t connect to the core anymore, and in the ARC settings tab, the Testing doesn’t complete.

I live in Germany, my internet provider is M-Net and I’m using a Fritzbox 7490.
Disabling UPnP didn’t make a difference in my case, the problem persists. Would be great to get a solution soon!

Hi @connor, I can confirm the update to B1226 also broke ARC due to the UPNP connection to my router ceasing to function.

As before the steps to fix this were

  1. Disable UPNP on router
  2. Reboot core (restart Roon is not sufficient)
  3. Re-enable UPNP on router

There is no need to do anything with the ARC app itself.

Any sign of a fix?

B1228 now installed, and ARC still working, so hopefully the issue has been resolved.