B1235 [and before] An absolute ton of my music has become untagged! [Resolved]

Content you’re reporting an issue with

Have you made any edits to this content in Roon?

Is the album identified in Roon?

Is this content from local files, TIDAL, or Qobuz?

Screenshot of import settings

Description of the issue

Did the latest update address any major ways in which Roon sees metadata?

Because hundreds, if not thousands, of my albums are suddenly appearing in all the wrong places with all the wrong meta-tags. Not the ones I’ve lovingly crafted over the last year.

This is just one example…

Here’s is how Yate sees the artist & album artist tags:
Screenshot 2023-03-17 at 18.04.10

Here is how Roon sees the artist & album artist tags:

And here is what Roon is doing to the album in the main window:

It’s filing under 94 East & not Prince even though everything, even Roon, is telling me the album artist is Prince!!!

Everything else is set to prefer file.

Is there anywhere else I should be looking?

It’s annoying but don’t worry too much, the information is still there as you can see in the edit window. It’s not lost. It just isn’t being correctly displayed and therefore also not ordered correctly. This will surely be fixed.

We have seen some similar issues recently where custom genres were not displayed although they were still there in the editor (now fixed), and I reported an issue in earlyaccess where tags on artists are currently not displayed although also still there in the tag editor.

It’s a bunch of annoying display issues that all seem to have to do with the upcoming (now being tested in earlyrelease) language-localized options in Roon. The groundwork has been laid for a while and is also in production builds already - earlyaccess testers were asked to look out for any metadata display problems and they found a few, but obviously haven’t managed to catch all of them.

1 Like

Thanks for the response. I am beyond furious, having just paid for another year.

I shall remain patient. :slightly_smiling_face:

@Snowdog, what build are you running on your core? Roon > Settings > About.

1 Like

Well, funnily enough, I just went there & as soon as I arrived, a progress bar started… progressing & it arrived at my needing to restart because of an update.

Strange that it didn’t prompt me about that like it usually does (without my having to go to “about”).

Anyway, I ran the update & Roon restarted.

Nothing seems to have changed. It’s still sorting “Steven Price” before 2, 4, 6 & 8:

But, to answer your question:

The rest of my set-up, for reference:

Apple MacBook Pro (15" 2017)
Ventura 13.2.1
3.1 GHz Quad-Core Intel Core i7
16GB 2133 MHz LPDDR3

Western Digital 18TB Elements Desktop External Hard Drive (Music library storage)

Virgin Media Hub 3 set to modem mode…
ASUS ZenWiFi AX router connected to laptop via cat-6 ethernet cables.
Virgin Media M350 Fibre Broadband

Raspberry Pi 4b with Allo BOSS DAC connected to router via ethernet & to analogue amp via standard phono.

You should be posting in #early-access probably. You alert the developers to the issue (the point of earlyaccess), get faster help, and don’t confuse or scare regular users.

(EA help)

And there is all the work ongoing for language-localized credits and genres in earlyaccess, where in some announcements they specifically asked to report any such display issues

1 Like


10 chars.


What appears to be happening is that some albums are being displayed by the “artist” field & “album artist” is being ignored.

It only seems to be happening on “identified” content, so the 111 disc box set “111 Years Of DG” filters to only 19 albums which are each showing as “unidentified”. The remaining 92 discs will be scattered around my library, presumably filing under the performer on each disc.

Well, imagine how excited I was to see an update!!

But… No change. Sadly everything is still displayed all wrong & renders Roon, to all intents & purposes, unusable in the normal way.

Of course, I can still play things… If only I could find them. :slight_smile:

IIRC you are using a Windows core? Did you follow the Windows specific update instructions that are currently a bit special and did you verify that you really updated to build 1237?

Asking because two somewhat similar display issues from 1235 were confirmed to be fixed on macOS and iPad with 1237, and if I see that correctly yours might not occur for me on iPad with 1237 either. At least in a quick test, I edited an album artist into an album:

And it looks fine on the album page if I understand your problem correctly:

1 Like

@Snowdog uses macOS.


Yes, I’m on a Mac. This is what “about” says after today’s update.

I haven’t been in & tried to change anything since the update. I’m just hoping that at some point it will all start to display correctly again without my having to remove & re-add, clear caches & all that other stuff.

But would you say that my test case looks as you would expect?

Unfortunately I can’t test on macOS right now because I poured a cup of hot cacao over my new Air and it’s in for a (costly) repair, so limited to iPad right now….

I would say that your test case is kind of correct. I tag my files in Yate so it would be the “prefer file” option that is already correct but that Roon is ignoring. If I go in & manually override it by typing something into that box, it then sorts where it’s supposed to.

But we are warned against that method. Firstly it would mean manually entering that information. Then, if our database were to become corrupted, all of that information would have to be manually entered again.

Better to have it part of the files & separate from Roon & its database.

Another thing that occurs to me…

There is always the possibility that, because I’m a “fringe” case & break a lot of Roon’s rules in order to get my music sorted the way I want it sorted, that they are changing things (then breaking things & then fixing things) which, in the end, will work well for someone who uses Roon “properly” but for me, my covert tactics might no longer work in the new Roon.

And there’s no reason at all that they’d feel any need to “fix” that.

Oh right, then your case may well be very different, my test was just a quick edit of the album artist in Roon directly, not in the file

Well, at least I know that will sort things the way I want them sorted, so it was worth it for finding that out.

Theoretically, if worst comes to the worst, I could tag all my files correctly, but group select things in Roon & globally edit that tag & override the meta-tag. A bit of a blunt instrument, but at least I now know how to globally remove an override, too, so it doesn’t seem like such a dead end solution. :slight_smile:

1 Like

I don’t know this will help you or not.
I also use Nucleus + with Mac and iPad, and edit tags using Yate. “Prefer file metadata” is working with B 1237 but not with B 1235 or 1228. After installing B 1237, I once disabled both internal and external SSDs and enabled them again. Then, rebuilding of the Roon database started, wheels kept circling and took a while.

Okay, well I disconnected & reconnected the Roon core (my laptop’s hard drive, not a Nucleus) & the external hard drive (not SSD) & there is no change.

Great idea but sadly not a solution in my case, assuming I did it correctly.