B155 ARC 'Download could not be initiated - please try again' [Ticket in]

I am unable to download local files in ARC 155, since installing it last night.

This feature was working fine on the previous build, and hasn’t been resolved by resetting ARC, and affects all albums I’ve tried to download so far.

All my apps are running the latest early access builds, including my Core. MacOS and iOS devices, all running the latest Apple OS versions.

I’m having the same issue. Arc is unable to initiate a download either over a wifi or a cellular connection. Also using Build 155.

Same here, trying in a remote wifi (which worked before)
EDIT: And on home wifi. Ah but now I see that I still have B150 because 155 is not yet in the Play Store.

Same issue. Running the latest early access builds. MacOS and iOS devices all running the latest Apple OS versions.

Same issue - even in home wifi.

Hi! Sorry for trouble, this is a known issue and the fix is going to be released in the upcoming early access release.




Try this work-around:
Initiate download and shut down Arc before it gets the chance to bring up the “Download could not be initiated” alert. Reopen Arc and you should find the new download in your Downloads list.
Hope it works for you. Worked for me!

B159 fixed that problem - at least for me

1 Like