B159 ARC Cannot access ARC after iPhone battery replacement

For some reason, after getting a battery replaced in my iPhone 11, I cannot access ARC anymore. I tried rebooting both my Roon core and my iPhone but no luck. I also deleted the ARC app and reinstalled it but that didn’t help either. I was on the early access program and wonder whether I need to delete the Test Flight app, thinking perhaps that may be an issue. Any thoughts?

Michael, did you download the ARC app from TestFlight? I’m not aware of any issues, as long as you are using B1228 of earlyaccess and B159 of ARC. Can you connect using the ARC to your Core over WiFi?

1 Like

Robert, I tried using ARC from TestFlight and it’s not connecting. I checked my Roon site, under the ARC tab, and it says all is good and that Roon ARC is “Ready.”

Just to confirm, ARC is not working through WiFi or cellular connection.

Have you tried resetting ARC from within the app on your iPhone under Settings (again, from within the ARC app)?

1 Like

Not sure what you are suggesting. I log into the ARC app and it indicates it is trying to connect to my Roon core. There are no settings per se in the app that I can see.

If you cannot get past the first screen where it is trying to connect to your Core, not sure how to reset it. The Reset Roon ARC button is at the bottom of the page of the ARC settings by selecting the gear icon at the top right of the ARC app.

I am tagging @support for assistance with what you are experiencing.

1 Like

i had a (perhaps) similar issue

Try deleting the port forwarding and reinstating it, that’s what seemed to work for me.



Oddly enough, I was able to get ARC working through an unusual circumstance. The solution: when my iPhone battery was replaced yesterday I suddenly discovered that my system clock was incorrect; after toggling the switch in settings to get the correct time, suddenly my system recognized ARC. Must have been a router/timing thing, I guess. On the other hand, perhaps the iPhone clock had nothing whatsoever to do with the issue and I randomly got lucky!


Hi all, we are aware of, and urgently working towards a fix for a bug preventing ARC’s connection with the core. If you are having sudden and inexplicable connection issues, let’s wait until we resolve that issue and see if that solves your problems. Apologies for any inconvenience this is causing. We’re on it.