Backup bug/oddity

My setup is as follows:

  • Core running on a linux-based server, connected to my LAN via a cable,
  • Music files located on the same server as Roon core, and
  • Using a Mac laptop and various phones as clients.

The various odd behaviors are as follows:

  • Scheduled backups: When I try to set the location to something like “servername:/foo/bar/backups”, I get the error message “Invalid path specified”. This is definitely a problem . . .

  • Manual backups: When I specify the location as “servername:/foo/bar/backups”, it does seem to work, but does not create the “RoonBackups” directory that (I thought) should be there. I guess this one isn’t such a big deal, but the inconsistency between my understanding and the actual behavior makes me think that something about backing up isn’t working properly . . .

Any thoughts? Thanks.


Moving this to #support for you.

Ugh, I should have put it here . . . Thx. :+1:

Hi Neil,

Have you read this KB article regarding setting up a shared folder? Are you trying to backup to the Mac?

Cheers, Greg

Hi @Neil_Hodge,

Where are you trying to set the backup location to? The Mac or a NAS share?


Hmmm . . . My intuition was that the “library” (i.e., the metadata: which songs, number of plays, tags, etc.) all lived where the “Core” instance is (the linux server), and my use of the Mac was solely to control the Core instance. If this were correct, I would have expected that setting a backup path would have been a path on the machine where Core was living. Is this not correct?


This is exactly how it works. You should see something like:


Here you can use the blue marked path segments in the top line to navigate to the respective folder by clicking on it. In the Folder Listing you can see the content of the current folder. A click on a folder name here will open this folder and add the folder to the top line. You can create a new folder in the current location by clicking on the button New Folder (bottom left).

NOTE: You don’t have to create the last folder named RoonBackups. Roon will create this folder.


Interesting . . . That is what it looks like. As follows:

where “splayer” is the name of the server. However, when I go and try to set the actual location I want, I see the following:

I don’t know how you manage to get that message as you have to select the backup location in the Choose folder to backup to dialog where it should be impossible to navigate to an invalid path.

You may have to provide more details about what you’re doing exactly if you need further help.

Hi @Neil_Hodge,

Can you provide some more information regarding your Linux Core? What OS is it running and how did you set this up? Did you use our EasyInstaller and set the appropriate permissions?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.